aboutsummaryrefslogtreecommitdiffstats
path: root/security/libgcrypt
diff options
context:
space:
mode:
authorcpm <cpm@FreeBSD.org>2016-06-18 07:00:27 +0800
committercpm <cpm@FreeBSD.org>2016-06-18 07:00:27 +0800
commitd09a2b825d4fd6aa4890f3a7b90e53136e13a51b (patch)
treebc36581be5be2beb225a0b3b58c3b53b422a74cf /security/libgcrypt
parent620e65968b1c655078a5ee23cc7819a02348f6c7 (diff)
downloadfreebsd-ports-gnome-d09a2b825d4fd6aa4890f3a7b90e53136e13a51b.tar.gz
freebsd-ports-gnome-d09a2b825d4fd6aa4890f3a7b90e53136e13a51b.tar.zst
freebsd-ports-gnome-d09a2b825d4fd6aa4890f3a7b90e53136e13a51b.zip
- Update to 1.7.1
- Remove unneeded patch (applied upstream) - Convert to new test framework https://lists.gnupg.org/pipermail/gnupg-announce/2016q2/000389.html PR: 210328 Reviewed by: amdmi3, junovitch (mentors) Approved by: amdmi3, junovitch (mentors) MFH: 2016Q2 Exp-run: antoine Differential Revision: D6865
Diffstat (limited to 'security/libgcrypt')
-rw-r--r--security/libgcrypt/Makefile6
-rw-r--r--security/libgcrypt/distinfo5
-rw-r--r--security/libgcrypt/files/patch-cipher_crc-intel-pclmul.c279
-rw-r--r--security/libgcrypt/files/patch-mpi_longlong.h8
-rw-r--r--security/libgcrypt/pkg-plist2
5 files changed, 10 insertions, 290 deletions
diff --git a/security/libgcrypt/Makefile b/security/libgcrypt/Makefile
index 3016dedc87c0..2466665ae5aa 100644
--- a/security/libgcrypt/Makefile
+++ b/security/libgcrypt/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= libgcrypt
-PORTVERSION= 1.7.0
+PORTVERSION= 1.7.1
CATEGORIES= security
MASTER_SITES= GNUPG
@@ -22,6 +22,7 @@ CONFIGURE_ARGS= --disable-drng-support --enable-static=yes
CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
CONFIGURE_TARGET=${ARCH:S/amd64/x86_64/}-portbld-${OPSYS:tl}${OSREL}
USE_LDCONFIG= yes
+TEST_TARGET= check
DOCS= AUTHORS ChangeLog ChangeLog-2011 INSTALL NEWS README \
README.GIT THANKS TODO doc/HACKING doc/README.apichanges
@@ -47,7 +48,4 @@ post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR}
-regression-test: build
- cd ${WRKSRC} && ${MAKE_CMD} check
-
.include <bsd.port.mk>
diff --git a/security/libgcrypt/distinfo b/security/libgcrypt/distinfo
index 2b0042ce387e..4ba799a6fee3 100644
--- a/security/libgcrypt/distinfo
+++ b/security/libgcrypt/distinfo
@@ -1,2 +1,3 @@
-SHA256 (libgcrypt-1.7.0.tar.bz2) = b0e67ea74474939913c4d9d9ef4ef5ec378efbe2bebe36389dee319c79bffa92
-SIZE (libgcrypt-1.7.0.tar.bz2) = 2840453
+TIMESTAMP = 1466077169
+SHA256 (libgcrypt-1.7.1.tar.bz2) = 450d9cfcbf1611c64dbe3bd04b627b83379ef89f11406d94c8bba305e36d7a95
+SIZE (libgcrypt-1.7.1.tar.bz2) = 2843435
diff --git a/security/libgcrypt/files/patch-cipher_crc-intel-pclmul.c b/security/libgcrypt/files/patch-cipher_crc-intel-pclmul.c
deleted file mode 100644
index 2b46d3f6220b..000000000000
--- a/security/libgcrypt/files/patch-cipher_crc-intel-pclmul.c
+++ /dev/null
@@ -1,279 +0,0 @@
---- cipher/crc-intel-pclmul.c.orig 2016-04-07 15:30:08 UTC
-+++ cipher/crc-intel-pclmul.c
-@@ -143,7 +143,7 @@ crc32_reflected_bulk (u32 *pcrc, const b
- [inbuf_2] "m" (inbuf[2 * 16]),
- [inbuf_3] "m" (inbuf[3 * 16]),
- [crc] "m" (*pcrc)
-- : );
-+ );
-
- inbuf += 4 * 16;
- inlen -= 4 * 16;
-@@ -151,7 +151,7 @@ crc32_reflected_bulk (u32 *pcrc, const b
- asm volatile ("movdqa %[k1k2], %%xmm4\n\t"
- :
- : [k1k2] "m" (consts->k[1 - 1])
-- : );
-+ );
-
- /* Fold by 4. */
- while (inlen >= 4 * 16)
-@@ -188,7 +188,7 @@ crc32_reflected_bulk (u32 *pcrc, const b
- [inbuf_1] "m" (inbuf[1 * 16]),
- [inbuf_2] "m" (inbuf[2 * 16]),
- [inbuf_3] "m" (inbuf[3 * 16])
-- : );
-+ );
-
- inbuf += 4 * 16;
- inlen -= 4 * 16;
-@@ -199,7 +199,7 @@ crc32_reflected_bulk (u32 *pcrc, const b
- :
- : [k3k4] "m" (consts->k[3 - 1]),
- [my_p] "m" (consts->my_p[0])
-- : );
-+ );
-
- /* Fold 4 to 1. */
-
-@@ -222,7 +222,7 @@ crc32_reflected_bulk (u32 *pcrc, const b
- "pxor %%xmm4, %%xmm0\n\t"
- :
- :
-- : );
-+ );
- }
- else
- {
-@@ -236,7 +236,7 @@ crc32_reflected_bulk (u32 *pcrc, const b
- [crc] "m" (*pcrc),
- [k3k4] "m" (consts->k[3 - 1]),
- [my_p] "m" (consts->my_p[0])
-- : );
-+ );
-
- inbuf += 16;
- inlen -= 16;
-@@ -256,7 +256,7 @@ crc32_reflected_bulk (u32 *pcrc, const b
- "pxor %%xmm1, %%xmm0\n\t"
- :
- : [inbuf] "m" (*inbuf)
-- : );
-+ );
-
- inbuf += 16;
- inlen -= 16;
-@@ -288,7 +288,7 @@ crc32_reflected_bulk (u32 *pcrc, const b
- [mask] "m" (crc32_partial_fold_input_mask[inlen]),
- [shl_shuf] "m" (crc32_refl_shuf_shift[inlen]),
- [shr_shuf] "m" (crc32_refl_shuf_shift[inlen + 16])
-- : );
-+ );
-
- inbuf += inlen;
- inlen -= inlen;
-@@ -318,7 +318,7 @@ crc32_reflected_bulk (u32 *pcrc, const b
- "pextrd $2, %%xmm0, %[out]\n\t"
- : [out] "=m" (*pcrc)
- : [k5] "m" (consts->k[5 - 1])
-- : );
-+ );
- }
-
- static inline void
-@@ -333,7 +333,7 @@ crc32_reflected_less_than_16 (u32 *pcrc,
- asm volatile ("movdqa %[my_p], %%xmm5\n\t"
- :
- : [my_p] "m" (consts->my_p[0])
-- : );
-+ );
-
- if (inlen == 1)
- {
-@@ -372,7 +372,7 @@ crc32_reflected_less_than_16 (u32 *pcrc,
- : [out] "=m" (*pcrc)
- : [in] "rm" (data),
- [crc] "rm" (crc)
-- : );
-+ );
- }
- else if (inlen == 4)
- {
-@@ -391,7 +391,7 @@ crc32_reflected_less_than_16 (u32 *pcrc,
- : [in] "m" (*inbuf),
- [crc] "m" (*pcrc),
- [my_p] "m" (consts->my_p[0])
-- : );
-+ );
- }
- else
- {
-@@ -404,14 +404,14 @@ crc32_reflected_less_than_16 (u32 *pcrc,
- [crc] "m" (*pcrc),
- [my_p] "m" (consts->my_p[0]),
- [k3k4] "m" (consts->k[3 - 1])
-- : );
-+ );
-
- if (inlen >= 8)
- {
- asm volatile ("movq %[inbuf], %%xmm0\n\t"
- :
- : [inbuf] "m" (*inbuf)
-- : );
-+ );
- if (inlen > 8)
- {
- asm volatile (/*"pinsrq $1, %[inbuf_tail], %%xmm0\n\t"*/
-@@ -422,7 +422,7 @@ crc32_reflected_less_than_16 (u32 *pcrc,
- : [inbuf_tail] "m" (inbuf[inlen - 8]),
- [merge_shuf] "m"
- (*crc32_merge9to15_shuf[inlen - 9])
-- : );
-+ );
- }
- }
- else
-@@ -435,7 +435,7 @@ crc32_reflected_less_than_16 (u32 *pcrc,
- [inbuf_tail] "m" (inbuf[inlen - 4]),
- [merge_shuf] "m"
- (*crc32_merge5to7_shuf[inlen - 5])
-- : );
-+ );
- }
-
- /* Final fold. */
-@@ -465,7 +465,7 @@ crc32_reflected_less_than_16 (u32 *pcrc,
- "pextrd $2, %%xmm0, %[out]\n\t"
- : [out] "=m" (*pcrc)
- : [k5] "m" (consts->k[5 - 1])
-- : );
-+ );
- }
- }
-
-@@ -477,7 +477,7 @@ crc32_bulk (u32 *pcrc, const byte *inbuf
- asm volatile ("movdqa %[bswap], %%xmm7\n\t"
- :
- : [bswap] "m" (*crc32_bswap_shuf)
-- : );
-+ );
-
- if (inlen >= 8 * 16)
- {
-@@ -497,7 +497,7 @@ crc32_bulk (u32 *pcrc, const byte *inbuf
- [inbuf_2] "m" (inbuf[2 * 16]),
- [inbuf_3] "m" (inbuf[3 * 16]),
- [crc] "m" (*pcrc)
-- : );
-+ );
-
- inbuf += 4 * 16;
- inlen -= 4 * 16;
-@@ -505,7 +505,7 @@ crc32_bulk (u32 *pcrc, const byte *inbuf
- asm volatile ("movdqa %[k1k2], %%xmm4\n\t"
- :
- : [k1k2] "m" (consts->k[1 - 1])
-- : );
-+ );
-
- /* Fold by 4. */
- while (inlen >= 4 * 16)
-@@ -546,7 +546,7 @@ crc32_bulk (u32 *pcrc, const byte *inbuf
- [inbuf_1] "m" (inbuf[1 * 16]),
- [inbuf_2] "m" (inbuf[2 * 16]),
- [inbuf_3] "m" (inbuf[3 * 16])
-- : );
-+ );
-
- inbuf += 4 * 16;
- inlen -= 4 * 16;
-@@ -557,7 +557,7 @@ crc32_bulk (u32 *pcrc, const byte *inbuf
- :
- : [k3k4] "m" (consts->k[3 - 1]),
- [my_p] "m" (consts->my_p[0])
-- : );
-+ );
-
- /* Fold 4 to 1. */
-
-@@ -580,7 +580,7 @@ crc32_bulk (u32 *pcrc, const byte *inbuf
- "pxor %%xmm4, %%xmm0\n\t"
- :
- :
-- : );
-+ );
- }
- else
- {
-@@ -595,7 +595,7 @@ crc32_bulk (u32 *pcrc, const byte *inbuf
- [crc] "m" (*pcrc),
- [k3k4] "m" (consts->k[3 - 1]),
- [my_p] "m" (consts->my_p[0])
-- : );
-+ );
-
- inbuf += 16;
- inlen -= 16;
-@@ -616,7 +616,7 @@ crc32_bulk (u32 *pcrc, const byte *inbuf
- "pxor %%xmm1, %%xmm0\n\t"
- :
- : [inbuf] "m" (*inbuf)
-- : );
-+ );
-
- inbuf += 16;
- inlen -= 16;
-@@ -650,7 +650,7 @@ crc32_bulk (u32 *pcrc, const byte *inbuf
- [mask] "m" (crc32_partial_fold_input_mask[inlen]),
- [shl_shuf] "m" (crc32_refl_shuf_shift[32 - inlen]),
- [shr_shuf] "m" (crc32_shuf_shift[inlen + 16])
-- : );
-+ );
-
- inbuf += inlen;
- inlen -= inlen;
-@@ -697,7 +697,7 @@ crc32_less_than_16 (u32 *pcrc, const byt
- asm volatile ("movdqa %[my_p], %%xmm5\n\t"
- :
- : [my_p] "m" (consts->my_p[0])
-- : );
-+ );
-
- if (inlen == 1)
- {
-@@ -774,14 +774,14 @@ crc32_less_than_16 (u32 *pcrc, const byt
- [crc] "m" (*pcrc),
- [my_p] "m" (consts->my_p[0]),
- [k3k4] "m" (consts->k[3 - 1])
-- : );
-+ );
-
- if (inlen >= 8)
- {
- asm volatile ("movq %[inbuf], %%xmm0\n\t"
- :
- : [inbuf] "m" (*inbuf)
-- : );
-+ );
- if (inlen > 8)
- {
- asm volatile (/*"pinsrq $1, %[inbuf_tail], %%xmm0\n\t"*/
-@@ -792,7 +792,7 @@ crc32_less_than_16 (u32 *pcrc, const byt
- : [inbuf_tail] "m" (inbuf[inlen - 8]),
- [merge_shuf] "m"
- (*crc32_merge9to15_shuf[inlen - 9])
-- : );
-+ );
- }
- }
- else
-@@ -805,7 +805,7 @@ crc32_less_than_16 (u32 *pcrc, const byt
- [inbuf_tail] "m" (inbuf[inlen - 4]),
- [merge_shuf] "m"
- (*crc32_merge5to7_shuf[inlen - 5])
-- : );
-+ );
- }
-
- /* Final fold. */
diff --git a/security/libgcrypt/files/patch-mpi_longlong.h b/security/libgcrypt/files/patch-mpi_longlong.h
index 44f38158a31c..249e29f0cb03 100644
--- a/security/libgcrypt/files/patch-mpi_longlong.h
+++ b/security/libgcrypt/files/patch-mpi_longlong.h
@@ -1,4 +1,4 @@
---- mpi/longlong.h.orig 2016-04-18 19:16:10 UTC
+--- mpi/longlong.h.orig 2016-06-16 11:43:39 UTC
+++ mpi/longlong.h
@@ -174,6 +174,7 @@ MA 02111-1307, USA. */
(pl) = __m0 * __m1; \
@@ -12,7 +12,7 @@
extern UDItype __udiv_qrnnd ();
# define UDIV_TIME 220
# endif /* !LONGLONG_STANDALONE */
-+# endif /* 0 */
++#endif /* 0 */
#endif /* __alpha */
/***************************************
@@ -20,8 +20,8 @@
"rJ" ((USItype)(al)), \
"rI" ((USItype)(bl)) \
__CLOBBER_CC)
--# if defined (__sparc_v8__)
-+# if defined (__sparc_v8__) || defined (__sparc__)
+-# if defined (__sparc_v8__) || defined(__sparcv8)
++# if defined (__sparc_v8__) || defined(__sparcv8) || defined(__sparc__)
/* Don't match immediate range because, 1) it is not often useful,
2) the 'I' flag thinks of the range as a 13 bit signed interval,
while we want to match a 13 bit interval, sign extended to 32 bits,
diff --git a/security/libgcrypt/pkg-plist b/security/libgcrypt/pkg-plist
index 275db01a9ef1..b6a2c15b76f8 100644
--- a/security/libgcrypt/pkg-plist
+++ b/security/libgcrypt/pkg-plist
@@ -6,6 +6,6 @@ include/gcrypt.h
lib/libgcrypt.a
lib/libgcrypt.so
lib/libgcrypt.so.20
-lib/libgcrypt.so.20.1.0
+lib/libgcrypt.so.20.1.1
man/man1/hmac256.1.gz
share/aclocal/libgcrypt.m4