aboutsummaryrefslogtreecommitdiffstats
path: root/security/libgcrypt
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2010-11-02 20:18:54 +0800
committerkwm <kwm@FreeBSD.org>2010-11-02 20:18:54 +0800
commit0e3c6d5062c302480439644abf8fd7cdcb304fc5 (patch)
treefe7843090763a1279880501850a7e799fdd5ff31 /security/libgcrypt
parent5aa7a9294734f57cccf1bbc3a225113fdc64e2f1 (diff)
downloadfreebsd-ports-gnome-0e3c6d5062c302480439644abf8fd7cdcb304fc5.tar.gz
freebsd-ports-gnome-0e3c6d5062c302480439644abf8fd7cdcb304fc5.tar.zst
freebsd-ports-gnome-0e3c6d5062c302480439644abf8fd7cdcb304fc5.zip
Fix linking with clang, and give longlong.h a simular treatment like was
done in 9-current so clang can build it on i386. Update LICENSE block, and remove md5 sum. PR: ports/151349 Submitted by: myself Approved by: Yamaguchi Hirohisa <umq@ueo.co.jp> (maintainer)
Diffstat (limited to 'security/libgcrypt')
-rw-r--r--security/libgcrypt/Makefile6
-rw-r--r--security/libgcrypt/distinfo1
-rw-r--r--security/libgcrypt/files/patch-mpi-longlong.h42
3 files changed, 46 insertions, 3 deletions
diff --git a/security/libgcrypt/Makefile b/security/libgcrypt/Makefile
index cd179057a170..c4f1db286fd0 100644
--- a/security/libgcrypt/Makefile
+++ b/security/libgcrypt/Makefile
@@ -15,10 +15,12 @@ COMMENT= General purpose crypto library based on code used in GnuPG
LIB_DEPENDS= gpg-error.0:${PORTSDIR}/security/libgpg-error
-LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
+LICENSE= GPLv2 LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING ${WRKSRC}/COPYING.LIB
+LICENSE_COMB= multi
USE_BZIP2= yes
USE_AUTOTOOLS= libtool:22
+USE_CSTD= gnu89
GNU_CONFIGURE= yes
CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
USE_LDCONFIG= yes
diff --git a/security/libgcrypt/distinfo b/security/libgcrypt/distinfo
index fcd8a4fb0782..2efe30de9186 100644
--- a/security/libgcrypt/distinfo
+++ b/security/libgcrypt/distinfo
@@ -1,3 +1,2 @@
-MD5 (libgcrypt-1.4.6.tar.bz2) = dbf99425a4fe9217c84ce3a35d938634
SHA256 (libgcrypt-1.4.6.tar.bz2) = 3e4b30da6b357b565333d0222133b64a0414be99ba72733081165c8ea9bc6b85
SIZE (libgcrypt-1.4.6.tar.bz2) = 1151877
diff --git a/security/libgcrypt/files/patch-mpi-longlong.h b/security/libgcrypt/files/patch-mpi-longlong.h
new file mode 100644
index 000000000000..a82c7188b0d5
--- /dev/null
+++ b/security/libgcrypt/files/patch-mpi-longlong.h
@@ -0,0 +1,42 @@
+--- ./mpi/longlong.h.orig 2010-02-22 19:04:43.000000000 +0900
++++ ./mpi/longlong.h 2010-11-01 18:25:34.000000000 +0900
+@@ -437,8 +437,8 @@
+ #define add_ssaaaa(sh, sl, ah, al, bh, bl) \
+ __asm__ ("addl %5,%1\n" \
+ "adcl %3,%0" \
+- : "=r" ((USItype)(sh)), \
+- "=&r" ((USItype)(sl)) \
++ : "=r" (sh), \
++ "=&r" (sl) \
+ : "%0" ((USItype)(ah)), \
+ "g" ((USItype)(bh)), \
+ "%1" ((USItype)(al)), \
+@@ -446,22 +446,22 @@
+ #define sub_ddmmss(sh, sl, ah, al, bh, bl) \
+ __asm__ ("subl %5,%1\n" \
+ "sbbl %3,%0" \
+- : "=r" ((USItype)(sh)), \
+- "=&r" ((USItype)(sl)) \
++ : "=r" (sh), \
++ "=&r" (sl) \
+ : "0" ((USItype)(ah)), \
+ "g" ((USItype)(bh)), \
+ "1" ((USItype)(al)), \
+ "g" ((USItype)(bl)))
+ #define umul_ppmm(w1, w0, u, v) \
+ __asm__ ("mull %3" \
+- : "=a" ((USItype)(w0)), \
+- "=d" ((USItype)(w1)) \
++ : "=a" (w0), \
++ "=d" (w1) \
+ : "%0" ((USItype)(u)), \
+ "rm" ((USItype)(v)))
+ #define udiv_qrnnd(q, r, n1, n0, d) \
+ __asm__ ("divl %4" \
+- : "=a" ((USItype)(q)), \
+- "=d" ((USItype)(r)) \
++ : "=a" (q), \
++ "=d" (r) \
+ : "0" ((USItype)(n0)), \
+ "1" ((USItype)(n1)), \
+ "rm" ((USItype)(d)))