aboutsummaryrefslogtreecommitdiffstats
path: root/security/libp11/Makefile
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2006-06-13 00:58:38 +0800
committerale <ale@FreeBSD.org>2006-06-13 00:58:38 +0800
commit221d3e23bdbb623a9c6ebe5fe29bb8a10eac5a00 (patch)
tree272857ccad594913b42b4ac518aabcb5022dfd8a /security/libp11/Makefile
parentcebdd46dbba073cd677c3fe05ec731b368c9621e (diff)
downloadfreebsd-ports-gnome-221d3e23bdbb623a9c6ebe5fe29bb8a10eac5a00.tar.gz
freebsd-ports-gnome-221d3e23bdbb623a9c6ebe5fe29bb8a10eac5a00.tar.zst
freebsd-ports-gnome-221d3e23bdbb623a9c6ebe5fe29bb8a10eac5a00.zip
Libp11 is a library implementing a small layer
on top of PKCS#11 API to make using PKCS#11 implementations easier. WWW: http://www.opensc-project.org/libp11/
Diffstat (limited to 'security/libp11/Makefile')
-rw-r--r--security/libp11/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/security/libp11/Makefile b/security/libp11/Makefile
new file mode 100644
index 000000000000..884de860daf0
--- /dev/null
+++ b/security/libp11/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: libp11
+# Date created: 1 Jun 2006
+# Whom: Alex Dupre <ale@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libp11
+PORTVERSION= 0.2.2
+CATEGORIES= security devel
+MASTER_SITES= http://www.opensc-project.org/files/${PORTNAME}/
+
+MAINTAINER= ale@FreeBSD.org
+COMMENT= A small layer on top of PKCS#11 API
+
+USE_AUTOTOOLS= libltdl:15
+USE_OPENSSL= yes
+GNU_CONFIGURE= yes
+USE_GNOME= gnomehack pkgconfig
+INSTALLS_SHLIB= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ OPENSSL_CFLAGS="-I${OPENSSLINC}" \
+ OPENSSL_LIBS="-L${OPENSSLLIB} -lssl"
+
+DOC_FILES= README *.sh *.xsl *.css *.html api
+
+PORTDOCS= *
+
+post-install:
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @(cd ${WRKSRC}/doc && ${CP} -R ${DOC_FILES} ${DOCSDIR})
+.endif
+
+.include <bsd.port.mk>