aboutsummaryrefslogtreecommitdiffstats
path: root/security/libparanoia
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-08-03 15:52:47 +0800
committersobomax <sobomax@FreeBSD.org>2002-08-03 15:52:47 +0800
commit5a6e98e7d50c5a61ec499254bcc5403a358fef9c (patch)
tree434ad4a81fc2a7673b6bf230cb96f97db5d06171 /security/libparanoia
parent97f5ceb76605f7f6b8895771cda2969c805a1ca1 (diff)
downloadfreebsd-ports-gnome-5a6e98e7d50c5a61ec499254bcc5403a358fef9c.tar.gz
freebsd-ports-gnome-5a6e98e7d50c5a61ec499254bcc5403a358fef9c.tar.zst
freebsd-ports-gnome-5a6e98e7d50c5a61ec499254bcc5403a358fef9c.zip
In gets(), two return's exist, and both should be wrapped with exit_violation.
In current version, one is forgotten. Bump PORTREVISION. PR: 41277 Submitted by: Valentin Nechayev <netch@netch.kiev.ua>
Diffstat (limited to 'security/libparanoia')
-rw-r--r--security/libparanoia/Makefile1
-rw-r--r--security/libparanoia/files/patch-ab14
2 files changed, 15 insertions, 0 deletions
diff --git a/security/libparanoia/Makefile b/security/libparanoia/Makefile
index 2da637f1a10a..c6065de59ec4 100644
--- a/security/libparanoia/Makefile
+++ b/security/libparanoia/Makefile
@@ -6,6 +6,7 @@
PORTNAME= libparanoia
PORTVERSION= 1.4
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ftp://ftp.lexa.ru/pub/domestic/snar/
diff --git a/security/libparanoia/files/patch-ab b/security/libparanoia/files/patch-ab
new file mode 100644
index 000000000000..43ff3e9a36ef
--- /dev/null
+++ b/security/libparanoia/files/patch-ab
@@ -0,0 +1,14 @@
+--- gets.c.orig Wed Dec 30 17:05:40 1998
++++ gets.c Fri Mar 22 23:29:05 2002
+@@ -68,8 +68,10 @@
+ }
+ for (s = buf; (c = getchar()) != '\n';)
+ if (c == EOF)
+- if (s == buf)
++ if (s == buf) {
++ exit_violation();
+ return (NULL);
++ }
+ else
+ break;
+ else