aboutsummaryrefslogtreecommitdiffstats
path: root/security/libpwstor
diff options
context:
space:
mode:
authoraraujo <araujo@FreeBSD.org>2008-10-25 00:08:00 +0800
committeraraujo <araujo@FreeBSD.org>2008-10-25 00:08:00 +0800
commitae220856f02db7ff2756626b8b76cde026537bed (patch)
tree0f1d8f663c68e74a4dc8f5bfd20c6c36ed7c84f1 /security/libpwstor
parent62e246e36585aaffa8f2143adf1844adf796f922 (diff)
downloadfreebsd-ports-gnome-ae220856f02db7ff2756626b8b76cde026537bed.tar.gz
freebsd-ports-gnome-ae220856f02db7ff2756626b8b76cde026537bed.tar.zst
freebsd-ports-gnome-ae220856f02db7ff2756626b8b76cde026537bed.zip
- libpwstor is a library implementing a password storage format
for C programmers. This format provides a reasonable level of security by utilizing SHA-256 in addition to a random salt to mitigate dictionary and rainbow table attacks. WWW: http://sourceforge.net/projects/kageki PR: ports/128328 Submitted by: Matt D. Harris <mattdharris@users.sourceforge.net> Reworked by: myself
Diffstat (limited to 'security/libpwstor')
-rw-r--r--security/libpwstor/Makefile56
-rw-r--r--security/libpwstor/distinfo3
-rw-r--r--security/libpwstor/pkg-descr13
3 files changed, 72 insertions, 0 deletions
diff --git a/security/libpwstor/Makefile b/security/libpwstor/Makefile
new file mode 100644
index 000000000000..77c938fa18c0
--- /dev/null
+++ b/security/libpwstor/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: libpwstor
+# Date created: 2008-10-23
+# Whom: Matt Harris <mattdharris@users.sourceforge.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libpwstor
+PORTVERSION= 0.1
+CATEGORIES= security devel
+MASTER_SITES= SF/kageki
+
+MAINTAINER= mattdharris@users.sourceforge.net
+COMMENT= A password storage library for C programmers
+
+USE_BZIP2= yes
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+
+PLIST_FILES= bin/pwtool \
+ include/pwstor.h \
+ lib/libpwstor.a \
+ lib/libpwstor.so \
+ lib/libpwstor.so.0.1
+
+MANCOMPESSED= no
+MAN1= pwtool.1
+MAN3= pwstor.3 \
+ pws_version.3 \
+ pws_version_int.3 \
+ pws_rand_get.3 \
+ pws_memnuke.3 \
+ pws_base64_encode.3 \
+ pws_base64_decode.3 \
+ pws_passwords_encode.3 \
+ pws_passwords_encodemulti.3 \
+ pws_passwords_len.3 \
+ pws_passwords_check.3 \
+ pws_passwords_checkmulti.3 \
+ pws_passwords_converttomulti.3
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+CFLAGS+= -fPIC -DPIC
+.endif
+
+.if ${OSVERSION} < 700000
+BROKEN= does not compile on FreeBSD 6.x
+.endif
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/libpwstor/distinfo b/security/libpwstor/distinfo
new file mode 100644
index 000000000000..76faf3f16d08
--- /dev/null
+++ b/security/libpwstor/distinfo
@@ -0,0 +1,3 @@
+MD5 (libpwstor-0.1.tar.bz2) = af9651a27c94b78daff9db1f071dbc06
+SHA256 (libpwstor-0.1.tar.bz2) = 5cdc05d6e94cd97a87bc1cd98d330f6231faed9f38ab5d15c490140a18de5abf
+SIZE (libpwstor-0.1.tar.bz2) = 48583
diff --git a/security/libpwstor/pkg-descr b/security/libpwstor/pkg-descr
new file mode 100644
index 000000000000..a7ec00061942
--- /dev/null
+++ b/security/libpwstor/pkg-descr
@@ -0,0 +1,13 @@
+libpwstor is a library implementing a password storage format
+for C programmers. This format provides a reasonable level of
+security by utilizing SHA-256 in addition to a random salt to
+mitigate dictionary and rainbow table attacks.
+
+In addition to the core functionality, libpwstor also offers
+some additional functions such as Base64 encoding and decoding.
+All functionality is implemented and designed in such a way as
+to be easy to use for C programmers of varying skill levels,
+while preserving reasonable security in the underlying storage
+format.
+
+WWW: http://sourceforge.net/projects/kageki