aboutsummaryrefslogtreecommitdiffstats
path: root/security/libssh/Makefile
diff options
context:
space:
mode:
authorlwhsu <lwhsu@FreeBSD.org>2009-04-13 01:47:48 +0800
committerlwhsu <lwhsu@FreeBSD.org>2009-04-13 01:47:48 +0800
commit2f097e92c1f7be980a48b442687a6175f5817710 (patch)
tree91ecffa2e02feba31ca85705072542a467daaee2 /security/libssh/Makefile
parentf01aa0b08ac58404a4f7ef09f852a6ceeb334459 (diff)
downloadfreebsd-ports-gnome-2f097e92c1f7be980a48b442687a6175f5817710.tar.gz
freebsd-ports-gnome-2f097e92c1f7be980a48b442687a6175f5817710.tar.zst
freebsd-ports-gnome-2f097e92c1f7be980a48b442687a6175f5817710.zip
Add libssh 0.2, a library implementing the SSH1 and SSH2 protocol.
PR: ports/133657 Submitted by: Alexander Logvinov <ports at logvinov.com>
Diffstat (limited to 'security/libssh/Makefile')
-rw-r--r--security/libssh/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/security/libssh/Makefile b/security/libssh/Makefile
new file mode 100644
index 000000000000..4a70b31ee3b8
--- /dev/null
+++ b/security/libssh/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: libssh
+# Date created: 12 April 2009
+# Whom: Alexander Logvinov <ports@logvinov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libssh
+PORTVERSION= 0.2
+CATEGORIES= security devel
+MASTER_SITES= http://0xbadc0de.be/libssh/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@logvinov.com
+COMMENT= A library implementing the SSH1 and SSH2 protocol
+
+MAKE_JOBS_SAFE= yes
+GNU_CONFIGURE= yes
+USE_OPENSSL= yes
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>