aboutsummaryrefslogtreecommitdiffstats
path: root/security/libssh2
diff options
context:
space:
mode:
authorsbz <sbz@FreeBSD.org>2012-07-16 18:47:28 +0800
committersbz <sbz@FreeBSD.org>2012-07-16 18:47:28 +0800
commitf393960934a7a3850f9e0ff88fa36fd0323aeec4 (patch)
tree6b0508ebfffa30684c69c188a16b81c4020b7976 /security/libssh2
parente02bbdebd199f44e948f5bdc32788201ede81be5 (diff)
downloadfreebsd-ports-gnome-f393960934a7a3850f9e0ff88fa36fd0323aeec4.tar.gz
freebsd-ports-gnome-f393960934a7a3850f9e0ff88fa36fd0323aeec4.tar.zst
freebsd-ports-gnome-f393960934a7a3850f9e0ff88fa36fd0323aeec4.zip
- Convert to OptionsNG
Diffstat (limited to 'security/libssh2')
-rw-r--r--security/libssh2/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/security/libssh2/Makefile b/security/libssh2/Makefile
index c5a02fbdc729..2aa9f2740d0a 100644
--- a/security/libssh2/Makefile
+++ b/security/libssh2/Makefile
@@ -23,26 +23,29 @@ USE_AUTOTOOLS= autoconf
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-OPTIONS= GCRYPT "Use libgcrypt instead of OpenSSL" off \
- TRACE "Enable debug packet traces" off \
- ZLIB "Enable compression" on
+OPTIONS_DEFINE= GCRYPT TRACE ZLIB
+OPTIONS_DEFAULT= ZLIB
+
+GCRYPT_DESC= Use libgcrypt instead of OpenSSL
+TRACE_DESC= Enable debug packet traces
+ZLIB_DESC= Enable compression
.include <bsd.port.pre.mk>
-.if defined(WITH_TRACE)
+.if ${PORT_OPTIONS:MTRACE}
CONFIGURE_ARGS+= --enable-debug
.else
CONFIGURE_ARGS+= --disable-debug
.endif
-.if defined(WITH_GCRYPT)
+.if ${PORT_OPTIONS:MGCRYPT}
LIB_DEPENDS+= gcrypt:${PORTSDIR}/security/libgcrypt
CONFIGURE_ARGS+= --with-libgcrypt -with-libgcrypt-prefix=${LOCALBASE} --without-openssl
-CFLAGS+=-I${LOCALBASE}/include
-LDFLAGS+=-L${LOCALBASE}/lib
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.endif
-.if defined(WITH_ZLIB)
+.if ${PORT_OPTIONS:MZLIB}
CONFIGURE_ARGS+= --with-libz
.else
CONFIGURE_ARGS+= --without-libz