aboutsummaryrefslogtreecommitdiffstats
path: root/security/libtomcrypt/Makefile
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2004-04-11 07:16:07 +0800
committerthierry <thierry@FreeBSD.org>2004-04-11 07:16:07 +0800
commit185e92021db914290dc5a11453f97c52916af474 (patch)
tree3bd442b408cd61b0284ea08dec3caed652f64409 /security/libtomcrypt/Makefile
parente2073cc7352e0a345c844f8dac5c951e32f7100f (diff)
downloadfreebsd-ports-gnome-185e92021db914290dc5a11453f97c52916af474.tar.gz
freebsd-ports-gnome-185e92021db914290dc5a11453f97c52916af474.tar.zst
freebsd-ports-gnome-185e92021db914290dc5a11453f97c52916af474.zip
Add libtomcrypt 0.92, comprehensive, modular and portable
cryptographic toolkit. PR: 62581 Submitted by: Yonatan <Yonatan@Xpert.com> Approved by: pav (mentor).
Diffstat (limited to 'security/libtomcrypt/Makefile')
-rw-r--r--security/libtomcrypt/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/security/libtomcrypt/Makefile b/security/libtomcrypt/Makefile
new file mode 100644
index 000000000000..8b01a2583ae4
--- /dev/null
+++ b/security/libtomcrypt/Makefile
@@ -0,0 +1,35 @@
+# Ports collection makefile for: libtomcrypt
+# Date created: 22 Jan 2004
+# Whom: Yonatan <Yonatan@Xpert.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libtomcrypt
+PORTVERSION= 0.92
+CATEGORIES= security
+MASTER_SITES= http://libtomcrypt.org/files/
+DISTNAME= crypt-${PORTVERSION}
+
+MAINTAINER= Yonatan@xpert.com
+COMMENT= Comprehensive, modular and portable cryptographic toolkit
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+MAKEFILE= makefile
+MAKE_ENV= PREFIX=${PREFIX} DOCSDIR=${DOCSDIR} EXAMPLESDIR=${EXAMPLESDIR}
+USE_BZIP2= yes
+ALL_TARGET= library
+
+.if defined(WITH_DOCS)
+BUILD_DEPENDS+= latex:${PORTSDIR}/print/teTeX
+.else
+NOPORTDOCS= yes
+INSTALL_TARGET= install-nodocs
+.endif
+
+.if defined(MAINTAINER_MODE)
+test: build
+ (cd ${WRKSRC} && ${MAKE} test && ${WRKSRC}/test)
+.endif
+
+.include <bsd.port.mk>