aboutsummaryrefslogtreecommitdiffstats
path: root/security/libtomcrypt/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-01-14 04:54:12 +0800
committerpav <pav@FreeBSD.org>2005-01-14 04:54:12 +0800
commit6fd0ab5d0754fba905c246178fbf388ef76b9294 (patch)
tree20f391b9be43cd1b4ba4597837d2e3b400ff32af /security/libtomcrypt/Makefile
parent277d98b19715136ee9ca7bd9c0400fc648c196e9 (diff)
downloadfreebsd-ports-gnome-6fd0ab5d0754fba905c246178fbf388ef76b9294.tar.gz
freebsd-ports-gnome-6fd0ab5d0754fba905c246178fbf388ef76b9294.tar.zst
freebsd-ports-gnome-6fd0ab5d0754fba905c246178fbf388ef76b9294.zip
- Update to 1.0
PR: ports/76185 Submitted by: Wesley Shields <wxs@csh.rit.edu> Approved by: Jonatan B <onatan@gmail.com> (maintained)
Diffstat (limited to 'security/libtomcrypt/Makefile')
-rw-r--r--security/libtomcrypt/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/security/libtomcrypt/Makefile b/security/libtomcrypt/Makefile
index 4c4a4e609341..5158aba23933 100644
--- a/security/libtomcrypt/Makefile
+++ b/security/libtomcrypt/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libtomcrypt
-PORTVERSION= 0.99
+PORTVERSION= 1.00
CATEGORIES= security
MASTER_SITES= http://libtomcrypt.org/files/
DISTNAME= crypt-${PORTVERSION}
@@ -16,24 +16,24 @@ COMMENT= Comprehensive, modular and portable cryptographic toolkit
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAKEFILE= makefile
+MAKE_ARGS+= PREFIX=${PREFIX}
MAKE_ENV= PREFIX=${PREFIX} DOCSDIR=${DOCSDIR} EXAMPLESDIR=${EXAMPLESDIR}
USE_BZIP2= yes
+USE_GMAKE= yes
USE_REINPLACE= yes
ALL_TARGET= library
.if defined(WITH_DOCS)
BUILD_DEPENDS+= latex:${PORTSDIR}/print/teTeX
+RUN_DEPENDS+= gs:${PORTSDIR}/print/ghostscript-gnu
.else
NOPORTDOCS= yes
-INSTALL_TARGET= install-nodocs
+INSTALL_TARGET= install_lib
.endif
.if defined(MAINTAINER_MODE)
test: build
- (cd ${WRKSRC} && ${MAKE} test && ${WRKSRC}/test)
+ (cd ${WRKSRC}/demos/test && ${MAKE} test ${MAKE_ARGS} && ${WRKSRC}/demos/test/test)
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's| ||' ${WRKSRC}/whirl.c
-
.include <bsd.port.mk>