aboutsummaryrefslogtreecommitdiffstats
path: root/security/libwhisker
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-11-26 21:08:24 +0800
committermat <mat@FreeBSD.org>2014-11-26 21:08:24 +0800
commit9debac461b7729b783ca5a0f5e46461ddac07173 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /security/libwhisker
parenteedda7c96f5b61bbadc957164c030b26a221e965 (diff)
downloadfreebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.tar.gz
freebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.tar.zst
freebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Diffstat (limited to 'security/libwhisker')
-rw-r--r--security/libwhisker/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/security/libwhisker/Makefile b/security/libwhisker/Makefile
index 28dfc1dec7a2..2585c4e4f796 100644
--- a/security/libwhisker/Makefile
+++ b/security/libwhisker/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libwhisker
PORTVERSION= 2.5
+PORTREVISION= 1
CATEGORIES= security perl5
MASTER_SITES= SF/whisker/${PORTNAME}/${PORTVERSION}
DISTNAME= ${PORTNAME}2-${PORTVERSION}
@@ -14,8 +15,7 @@ LICENSE= BSD2CLAUSE
NO_BUILD= yes
USES= perl5
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VER}
-PLIST_FILES= ${SITE_PERL_REL}/LW2.pm \
+PLIST_FILES= %%SITE_PERL%%/LW2.pm \
%%PERL5_MAN3%%/LW2.3pm.gz
OPTIONS_DEFINE= DOCS
@@ -23,11 +23,8 @@ OPTIONS_DEFINE= DOCS
PORTDOCS= *
do-install:
- @${MKDIR} ${STAGEDIR}${SITE_PERL}
- @${MKDIR} ${STAGEDIR}${MAN3PREFIX}/man/man3
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}/man/man3
cd ${WRKSRC} && ${SETENV} DESTDIR=${STAGEDIR} ${PERL5} Makefile.pl install
- @${CHMOD} 444 ${STAGEDIR}${SITE_PERL}/LW2.pm
- @${CHMOD} 444 ${STAGEDIR}${MAN3PREFIX}/man/man3/LW2.3pm
@${MKDIR} ${STAGEDIR}${DOCSDIR}/docs
@${MKDIR} ${STAGEDIR}${DOCSDIR}/scripts
cd ${WRKSRC} && ${INSTALL_DATA} README CHANGES KNOWNBUGS ${STAGEDIR}${DOCSDIR}