aboutsummaryrefslogtreecommitdiffstats
path: root/security/linux-c6-libgcrypt/Makefile
diff options
context:
space:
mode:
authorxmj <xmj@FreeBSD.org>2014-09-22 18:40:00 +0800
committerxmj <xmj@FreeBSD.org>2014-09-22 18:40:00 +0800
commitd39787ca07e42b7a91488f45cc6c58333ae10780 (patch)
treef0614b64c20d137667eadfbdc5663150937dc6c3 /security/linux-c6-libgcrypt/Makefile
parent143e62b0f3ebf9f9c709e4c068013418325fc64c (diff)
downloadfreebsd-ports-gnome-d39787ca07e42b7a91488f45cc6c58333ae10780.tar.gz
freebsd-ports-gnome-d39787ca07e42b7a91488f45cc6c58333ae10780.tar.zst
freebsd-ports-gnome-d39787ca07e42b7a91488f45cc6c58333ae10780.zip
Update CentOS base to 6.5, add userland ports
The Fedora 10 infrastructure ports have been in use since June 2009 and, while having served a great deed, have become unsupported upstream and hence affected by unfixed security vulnerabilities. In addition to that, many recent Linux binaries need newer libc / stdlibc++ versions. This commit adds the linux-c6- userland as drop-in replacement for the -f10 infrastructure, as well as upgrading the linux_base-c6 port to CentOS 6.5. If you want to switch to linux-c6 ports, please define at /etc/make.conf: OVERRIDE_LINUX_BASE_PORT=c6 OVERRIDE_LINUX_NONBASE_PORTS=c6 Additionally, please add the following line to /etc/sysctl.conf: compat.linux.osrelease=2.6.18 Upgrading procedures are shown in /usr/ports/UPDATING. This work has been inspired by Artyom Mirgorodskiy's post to emulation@ in November 2013, using and extending mav@'s work. It has been tested extensively and most reported issues were already fixed. Please report any additional bug or "features" to the emulation mailing list. Many thanks to: mav@, rene@, allanjude@, netchild@, antoine@, everyone who's filed Issues and Pull requests on GitHub, PR: 186820 Differential Revision: https://reviews.freebsd.org/D793 Reviewed by: allanjude, antoine, bapt, rene Approved by: portmgr (antoine, bapt) Approved by: koobs (mentor) Sponsored by: Perceivon Hosting Inc.
Diffstat (limited to 'security/linux-c6-libgcrypt/Makefile')
-rw-r--r--security/linux-c6-libgcrypt/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/security/linux-c6-libgcrypt/Makefile b/security/linux-c6-libgcrypt/Makefile
new file mode 100644
index 000000000000..ae1feb937125
--- /dev/null
+++ b/security/linux-c6-libgcrypt/Makefile
@@ -0,0 +1,25 @@
+# Created by: Johannes Meixner <xmj@chaot.net>
+# $FreeBSD$
+
+PORTNAME= libgcrypt
+PORTVERSION= 1.4.5
+CATEGORIES= security linux
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= General purpose crypto library based on code used in GnuPG (Linux CentOS ${LINUX_DIST_VER})
+
+USE_LINUX= c6
+USE_LINUX_RPM= yes
+RPMVERSION= 11.el6_4
+USE_LDCONFIG= yes
+
+PLIST_FILES= lib/libgcrypt.so.11 lib/.libgcrypt.so.11.hmac lib/libgcrypt.so.11.5.3
+PLIST_DIRSTRY= etc/gcrypt
+DOCSDIR= usr/share/doc/${PORTNAME}-${PORTVERSION}
+PORTDOCS= AUTHORS COPYING.LIB NEWS THANKS
+DESCR= ${.CURDIR}/../libgcrypt/pkg-descr
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/etc/gcrypt
+
+.include <bsd.port.mk>