aboutsummaryrefslogtreecommitdiffstats
path: root/security/logcheck
diff options
context:
space:
mode:
authorpat <pat@FreeBSD.org>2002-06-24 04:39:23 +0800
committerpat <pat@FreeBSD.org>2002-06-24 04:39:23 +0800
commit68d2ede20fe929082f7b63b1201632f02303de36 (patch)
tree7e1b667a7934284fdee094f1247ef35f0b6ea264 /security/logcheck
parentf7ba4a230537a78bfca3bc8765e6ad35ec5d318d (diff)
downloadfreebsd-ports-gnome-68d2ede20fe929082f7b63b1201632f02303de36.tar.gz
freebsd-ports-gnome-68d2ede20fe929082f7b63b1201632f02303de36.tar.zst
freebsd-ports-gnome-68d2ede20fe929082f7b63b1201632f02303de36.zip
PERL -> REINPLACE_CMD
PR: ports/39729, ports/39727, ports/39726, ports/39724 PR: ports/39722, ports/39721, ports/39720, ports/39719, ports/39718 Submitted by: Scott Flatman <sf@dsinw.com>
Diffstat (limited to 'security/logcheck')
-rw-r--r--security/logcheck/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/security/logcheck/Makefile b/security/logcheck/Makefile
index 2a6409b82c31..801935cc7479 100644
--- a/security/logcheck/Makefile
+++ b/security/logcheck/Makefile
@@ -13,14 +13,15 @@ DISTNAME= logsentry-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
+USE_REINPLACE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PKGMESSAGE= ${WRKDIR}/MESSAGE
pre-configure:
- ${PERL} -pi -e "s@/usr/local/etc/tmp@${PREFIX}/var/tmp@g; \
+ ${REINPLACE_CMD} -e "s@/usr/local/etc/tmp@${PREFIX}/var/tmp@g; \
s@/usr/local@${PREFIX}@" ${WRKSRC}/Makefile \
${WRKSRC}/systems/freebsd/logcheck.sh
- ${PERL} -pi -e "s@/bin/mkdir@${MKDIR}@g" ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e "s@/bin/mkdir@${MKDIR}@g" ${WRKSRC}/Makefile
post-build:
@${SED} -e 's,%%PREFIX%%,${PREFIX},g' ${PKGDIR}/pkg-message > ${PKGMESSAGE}