aboutsummaryrefslogtreecommitdiffstats
path: root/security/lsh/Makefile
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2003-06-13 12:26:24 +0800
committerdinoex <dinoex@FreeBSD.org>2003-06-13 12:26:24 +0800
commitabf2d47d56c61d96940b08b45b82a7ec37ad167e (patch)
tree6530e3a104ed5cd1539fb7700670f6cd7a4cd13d /security/lsh/Makefile
parentf0fe7dcff5ac17905bf0b0567a0871b2a399f198 (diff)
downloadfreebsd-ports-gnome-abf2d47d56c61d96940b08b45b82a7ec37ad167e.tar.gz
freebsd-ports-gnome-abf2d47d56c61d96940b08b45b82a7ec37ad167e.tar.zst
freebsd-ports-gnome-abf2d47d56c61d96940b08b45b82a7ec37ad167e.zip
- Update to 1.5.2
- removed patches that are now part of distribution - New option: WITH_THREADS or WITH_LSH_THREADS
Diffstat (limited to 'security/lsh/Makefile')
-rw-r--r--security/lsh/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/security/lsh/Makefile b/security/lsh/Makefile
index 5b53b6788386..1a113c691514 100644
--- a/security/lsh/Makefile
+++ b/security/lsh/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= lsh
-PORTVERSION= 1.5.1
+PORTVERSION= 1.5.2
CATEGORIES= security ipv6
MASTER_SITES= ${MASTER_SITE_GNUPG} \
ftp://ftp.lysator.liu.se/pub/security/%SUBDIR%/
@@ -24,14 +24,16 @@ USE_GMAKE= yes
INSTALL_TARGET= install
CONFIGURE_ARGS+= --with-include-path=${LOCALBASE}/include
CONFIGURE_ARGS+= --with-lib-path=${LOCALBASE}/lib
-LDFLAGS+= ${PTHREAD_LIBS}
-CFLAGS+= ${PTHREAD_CFLAGS:S=""==}
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
.if defined(KRB5_HOME) && exists(${KRB5_HOME})
PLIST_SUB+= KRB=""
.else
PLIST_SUB+= KRB="@comment "
.endif
+.if defined(WITH_THREADS) || defined(WITH_LSH_THREADS)
+LDFLAGS+= ${PTHREAD_LIBS}
+CFLAGS+= ${PTHREAD_CFLAGS:S=""==}
+.endif
.include <bsd.port.pre.mk>