aboutsummaryrefslogtreecommitdiffstats
path: root/security/luasec/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-11-24 23:55:53 +0800
committermiwi <miwi@FreeBSD.org>2011-11-24 23:55:53 +0800
commit7e2618470d2f14d8d213da85993afcb4435624b3 (patch)
treed0a0fa23d49216123cb5394eea7fd1fb623f781e /security/luasec/Makefile
parent2029fb25f09b2b108b2d0554301664898b14b08b (diff)
downloadfreebsd-ports-gnome-7e2618470d2f14d8d213da85993afcb4435624b3.tar.gz
freebsd-ports-gnome-7e2618470d2f14d8d213da85993afcb4435624b3.tar.zst
freebsd-ports-gnome-7e2618470d2f14d8d213da85993afcb4435624b3.zip
- Respect CC/CFLAGS
PR: 162533 Submitted by: Jan Beich <jbeich@tormail.net> Approved by: maintainer Feature safe: yes
Diffstat (limited to 'security/luasec/Makefile')
-rw-r--r--security/luasec/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/security/luasec/Makefile b/security/luasec/Makefile
index 7600a1be6698..c596fa23c877 100644
--- a/security/luasec/Makefile
+++ b/security/luasec/Makefile
@@ -33,4 +33,11 @@ USE_OPENSSL= yes
USE_OPENSSL_PORT=yes
.endif
+post-patch: .SILENT
+ ${REINPLACE_CMD} -Ee '/^CC/s/=/?=/' \
+ -e '/^LD/s/gcc/$$(CC)/' \
+ -e '/^(C|LD)FLAGS/s/=/+=/' \
+ -e '/^BSD/{s/-O[0-3]?//;}' \
+ ${WRKSRC}/src/Makefile
+
.include <bsd.port.mk>