aboutsummaryrefslogtreecommitdiffstats
path: root/security/mailzu
diff options
context:
space:
mode:
authorsahil <sahil@FreeBSD.org>2010-11-27 14:48:59 +0800
committersahil <sahil@FreeBSD.org>2010-11-27 14:48:59 +0800
commitcd0aa3a015844c1da2e54312b02a9763b64dcde8 (patch)
tree2d683b9095f233b404f2b2b4dc06c6a649d97392 /security/mailzu
parent4076731781d52c08d94b620d81cf678ac774f3e0 (diff)
downloadfreebsd-ports-gnome-cd0aa3a015844c1da2e54312b02a9763b64dcde8.tar.gz
freebsd-ports-gnome-cd0aa3a015844c1da2e54312b02a9763b64dcde8.tar.zst
freebsd-ports-gnome-cd0aa3a015844c1da2e54312b02a9763b64dcde8.zip
Add a patch to fix quarantine summary in overview. Also
make a note in pkg-message that PHP's short_open_tag boolean should be true for proper operation of MailZu. While here, remove MD5 checksum from distinfo. Bump PORTREVISION as this affects the package. PR: ports/152540 Submitted by: Michael Ranner <michael@ranner.eu>
Diffstat (limited to 'security/mailzu')
-rw-r--r--security/mailzu/Makefile4
-rw-r--r--security/mailzu/distinfo1
-rw-r--r--security/mailzu/files/patch-lib-DBEngine.class.php134
-rw-r--r--security/mailzu/files/pkg-message.in6
4 files changed, 142 insertions, 3 deletions
diff --git a/security/mailzu/Makefile b/security/mailzu/Makefile
index 8f2d658f2809..73970247f9a1 100644
--- a/security/mailzu/Makefile
+++ b/security/mailzu/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mailzu
DISTVERSION= 0.8rc3
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/MailZu%200.8RC3
DISTNAME= MailZu_${DISTVERSION:S/rc/RC/}
@@ -63,7 +64,8 @@ PORTDOCS= *
do-install:
@${INSTALL} -d -o ${WWWOWN} -g ${WWWGRP} -m 755 ${WWWDIR}
@${INSTALL_DATA} ${WRKSRC}/*.php* ${WRKSRC}/*.js* ${WRKSRC}/*.css* ${WWWDIR}
- @cd ${WRKSRC} && ${COPYTREE_SHARE} "config contrib img lang lib templates" ${WWWDIR}
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} "config contrib img lang lib templates" \
+ ${WWWDIR} "! -name *.orig"
@cd ${WRKSRC} && ${COPYTREE_BIN} scripts ${WWWDIR}
post-install:
diff --git a/security/mailzu/distinfo b/security/mailzu/distinfo
index 92e3b681b725..baed3e4db905 100644
--- a/security/mailzu/distinfo
+++ b/security/mailzu/distinfo
@@ -1,3 +1,2 @@
-MD5 (MailZu_0.8RC3.tar.gz) = 9c50ed9d468a4a932b625bfe1f835b3d
SHA256 (MailZu_0.8RC3.tar.gz) = aec449f13642e0003eabe9d6a3daa4b8cfebe6d58b8dc9438aee0fec80a1ecc8
SIZE (MailZu_0.8RC3.tar.gz) = 543781
diff --git a/security/mailzu/files/patch-lib-DBEngine.class.php b/security/mailzu/files/patch-lib-DBEngine.class.php
new file mode 100644
index 000000000000..a1b7c75134d9
--- /dev/null
+++ b/security/mailzu/files/patch-lib-DBEngine.class.php
@@ -0,0 +1,134 @@
+--- lib/DBEngine.class.php.orig 2010-11-24 11:32:33.000000000 +0100
++++ lib/DBEngine.class.php 2010-11-24 11:32:41.000000000 +0100
+@@ -132,7 +132,7 @@
+ MAX(stattable.badheaders) AS badheaders,
+ MAX(stattable.pending) AS pending
+ FROM (
+- SELECT CAST(time_iso AS DATE) AS date,
++ SELECT CAST(FROM_UNIXTIME(time_num) AS DATE) AS date,
+ COUNT(content) AS spam,
+ 0 AS banned,
+ 0 AS viruses,
+@@ -141,9 +141,9 @@
+ FROM msgs INNER JOIN msgrcpt ON msgs.mail_id=msgrcpt.mail_id
+ WHERE content='S' AND NOT (msgs.quar_type = '')
+ AND msgrcpt.rs IN ('','v')
+- GROUP BY CAST(time_iso AS DATE)
++ GROUP BY CAST(FROM_UNIXTIME(time_num) AS DATE)
+ UNION
+- SELECT CAST(time_iso AS DATE) AS date,
++ SELECT CAST(FROM_UNIXTIME(time_num) AS DATE) AS date,
+ 0 AS spam,
+ COUNT(content) AS banned,
+ 0 AS viruses,
+@@ -152,9 +152,9 @@
+ FROM msgs INNER JOIN msgrcpt ON msgs.mail_id=msgrcpt.mail_id
+ WHERE content='B' AND NOT (msgs.quar_type = '')
+ AND msgrcpt.rs IN ('','v')
+- GROUP BY CAST(time_iso AS DATE)
++ GROUP BY CAST(FROM_UNIXTIME(time_num) AS DATE)
+ UNION
+- SELECT CAST(time_iso AS DATE) AS date,
++ SELECT CAST(FROM_UNIXTIME(time_num) AS DATE) AS date,
+ 0 AS spam,
+ 0 AS banned,
+ COUNT(content) AS viruses,
+@@ -163,9 +163,9 @@
+ FROM msgs INNER JOIN msgrcpt ON msgs.mail_id=msgrcpt.mail_id
+ WHERE content='V' AND NOT (msgs.quar_type = '')
+ AND msgrcpt.rs IN ('','v')
+- GROUP BY CAST(time_iso AS DATE)
++ GROUP BY CAST(FROM_UNIXTIME(time_num) AS DATE)
+ UNION
+- SELECT CAST(time_iso AS DATE) AS date,
++ SELECT CAST(FROM_UNIXTIME(time_num) AS DATE) AS date,
+ 0 AS spam,
+ 0 AS banned,
+ 0 AS viruses,
+@@ -174,9 +174,9 @@
+ FROM msgs INNER JOIN msgrcpt ON msgs.mail_id=msgrcpt.mail_id
+ WHERE content='H' AND NOT (msgs.quar_type = '')
+ AND msgrcpt.rs IN ('','v')
+- GROUP BY CAST(time_iso AS DATE)
++ GROUP BY CAST(FROM_UNIXTIME(time_num) AS DATE)
+ UNION
+- SELECT CAST(time_iso AS DATE) AS date,
++ SELECT CAST(FROM_UNIXTIME(time_num) AS DATE) AS date,
+ 0 AS spam,
+ 0 AS banned,
+ 0 AS viruses,
+@@ -184,7 +184,7 @@
+ COUNT(content) AS pending
+ FROM msgs JOIN msgrcpt ON msgs.mail_id=msgrcpt.mail_id
+ WHERE msgrcpt.rs='p' AND NOT (msgs.quar_type = '')
+- GROUP BY CAST(time_iso AS DATE)
++ GROUP BY CAST(FROM_UNIXTIME(time_num) AS DATE)
+ ) AS stattable
+ GROUP BY date
+ ORDER BY date";
+@@ -253,7 +253,7 @@
+ MAX(stattable.badheaders) AS badheaders,
+ MAX(stattable.pending) AS pending
+ FROM (
+- SELECT CAST(time_iso AS DATE) AS date,
++ SELECT CAST(FROM_UNIXTIME(time_num) AS DATE) AS date,
+ COUNT(content) AS spam,
+ 0 AS banned,
+ 0 AS viruses,
+@@ -263,9 +263,9 @@
+ $join_type maddr AS recip ON msgrcpt.rid=recip.id
+ WHERE content='S' AND NOT (msgs.quar_type = '') AND msgrcpt.rs IN ('','v')
+ AND $recipEmailClause
+- GROUP BY CAST(time_iso AS DATE)
++ GROUP BY CAST(FROM_UNIXTIME(time_num) AS DATE)
+ UNION
+- SELECT CAST(time_iso AS DATE) AS date,
++ SELECT CAST(FROM_UNIXTIME(time_num) AS DATE) AS date,
+ 0 AS spam,
+ COUNT(content) AS banned,
+ 0 AS viruses,
+@@ -275,9 +275,9 @@
+ $join_type maddr AS recip ON msgrcpt.rid=recip.id
+ WHERE content='B' AND NOT (msgs.quar_type = '') AND msgrcpt.rs IN ('','v')
+ AND $recipEmailClause
+- GROUP BY CAST(time_iso AS DATE)
++ GROUP BY CAST(FROM_UNIXTIME(time_num) AS DATE)
+ UNION
+- SELECT CAST(time_iso AS DATE) AS date,
++ SELECT CAST(FROM_UNIXTIME(time_num) AS DATE) AS date,
+ 0 AS spam,
+ 0 AS banned,
+ COUNT(content) AS viruses,
+@@ -287,9 +287,9 @@
+ $join_type maddr AS recip ON msgrcpt.rid=recip.id
+ WHERE content='V' AND NOT (msgs.quar_type = '') AND msgrcpt.rs IN ('','v')
+ AND $recipEmailClause
+- GROUP BY CAST(time_iso AS DATE)
++ GROUP BY CAST(FROM_UNIXTIME(time_num) AS DATE)
+ UNION
+- SELECT CAST(time_iso AS DATE) AS date,
++ SELECT CAST(FROM_UNIXTIME(time_num) AS DATE) AS date,
+ 0 AS spam,
+ 0 AS banned,
+ 0 AS viruses,
+@@ -299,9 +299,9 @@
+ $join_type maddr AS recip ON msgrcpt.rid=recip.id
+ WHERE content='H' AND NOT (msgs.quar_type = '') AND msgrcpt.rs IN ('','v')
+ AND $recipEmailClause
+- GROUP BY CAST(time_iso AS DATE)
++ GROUP BY CAST(FROM_UNIXTIME(time_num) AS DATE)
+ UNION
+- SELECT CAST(time_iso AS DATE) AS date,
++ SELECT CAST(FROM_UNIXTIME(time_num) AS DATE) AS date,
+ 0 AS spam,
+ 0 AS banned,
+ 0 AS viruses,
+@@ -311,7 +311,7 @@
+ $join_type maddr AS recip ON msgrcpt.rid=recip.id
+ WHERE msgrcpt.rs='p' AND NOT (msgs.quar_type = '')
+ AND $recipEmailClause
+- GROUP BY CAST(time_iso AS DATE)
++ GROUP BY CAST(FROM_UNIXTIME(time_num) AS DATE)
+ ) AS stattable
+ GROUP BY date
+ ORDER BY date";
diff --git a/security/mailzu/files/pkg-message.in b/security/mailzu/files/pkg-message.in
index 1d228fc15d16..8218fc8efd03 100644
--- a/security/mailzu/files/pkg-message.in
+++ b/security/mailzu/files/pkg-message.in
@@ -9,6 +9,11 @@ Please read: %%DOCSDIR%%/INSTALL
Then, create and edit %%WWWDIR%%/config/config.php
An example is provided in %%WWWDIR%%/config/config.php.sample
+Also, please note that MailZu needs PHP's short_open_tag
+boolean to be "on" (this is detault in typical installations
+of PHP). To be certain, you can set "short_open_tag = on" in
+%%LOCALBASE%%/etc/php.ini.
+
Finally, make MailZu available through your web site. An
example for httpd.conf:
@@ -21,4 +26,3 @@ Alias /mailzu/ "%%WWWDIR%%/"
Deny from all
Allow from 127.0.0.1 .example.org
</Directory>
-