aboutsummaryrefslogtreecommitdiffstats
path: root/security/makepasswd/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-04-01 16:04:10 +0800
committeredwin <edwin@FreeBSD.org>2003-04-01 16:04:10 +0800
commit37ca737cfb67a02f42f2d6f125ebc28af32fe809 (patch)
treecca49ea3c4d524174e09b6bdec88caa196870939 /security/makepasswd/Makefile
parent46fa04acb3304a9d1729eac1ba122e6b4de861c1 (diff)
downloadfreebsd-ports-gnome-37ca737cfb67a02f42f2d6f125ebc28af32fe809.tar.gz
freebsd-ports-gnome-37ca737cfb67a02f42f2d6f125ebc28af32fe809.tar.zst
freebsd-ports-gnome-37ca737cfb67a02f42f2d6f125ebc28af32fe809.zip
New port: makepasswd, random password generator
Random password generator. PR: ports/49008 Submitted by: Toni Viemero <toni.viemero@iki.fi>
Diffstat (limited to 'security/makepasswd/Makefile')
-rw-r--r--security/makepasswd/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/security/makepasswd/Makefile b/security/makepasswd/Makefile
new file mode 100644
index 000000000000..2e69dd8962f0
--- /dev/null
+++ b/security/makepasswd/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: makepasswd
+# Date created: 7 March 2003
+# Whom: Toni Viemerö <toni.viemero@iki.fi>
+#
+# $FreeBSD$
+#
+
+PORTNAME= makepasswd
+PORTVERSION= 1.10
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_DEBIAN}
+MASTER_SITE_SUBDIR= dists/potato/main/source/admin/
+DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
+
+MAINTAINER= toni.viemero@iki.fi
+COMMENT= Random password generator
+
+NO_BUILD= yes
+USE_PERL5_RUN= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+MAN1= makepasswd.1
+DOCS= CHANGES README
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/makepasswd ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>