aboutsummaryrefslogtreecommitdiffstats
path: root/security/medusa
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-07-06 18:52:53 +0800
committermarino <marino@FreeBSD.org>2014-07-06 18:52:53 +0800
commit20feb146c6c20711aad1b7baef2792c727027e0a (patch)
tree110195a7d18fb3afb271b2ad7793242f1cb47f11 /security/medusa
parent5fafd4d5fe64b845086acc4fdb6ddf303b879ce3 (diff)
downloadfreebsd-ports-gnome-20feb146c6c20711aad1b7baef2792c727027e0a.tar.gz
freebsd-ports-gnome-20feb146c6c20711aad1b7baef2792c727027e0a.tar.zst
freebsd-ports-gnome-20feb146c6c20711aad1b7baef2792c727027e0a.zip
security/medusa: upgrade 2.1 => 2.1.1, stage, unbreak F10+
This port was upgraded with the belief that medusa.c was fixed for clang, but actually it still needs a patch. However, the upgrade did remove the bogus -module switch that modern gcc dislikes. While staging: * sort pkg-plist * convert to new LIB_DEPENDS format * libpcre no longer required, so remove it * dump <pre>, <post> in favor of <options> * leverage OPTIONS for PLIST * clean up, pet portlint
Diffstat (limited to 'security/medusa')
-rw-r--r--security/medusa/Makefile37
-rw-r--r--security/medusa/distinfo4
-rw-r--r--security/medusa/files/patch-src_medusa.c54
-rw-r--r--security/medusa/pkg-descr2
-rw-r--r--security/medusa/pkg-plist39
5 files changed, 91 insertions, 45 deletions
diff --git a/security/medusa/Makefile b/security/medusa/Makefile
index e2ac5c0c695a..702428e5fd43 100644
--- a/security/medusa/Makefile
+++ b/security/medusa/Makefile
@@ -2,57 +2,48 @@
# $FreeBSD$
PORTNAME= medusa
-PORTVERSION= 2.1
-PORTREVISION= 1
+PORTVERSION= 2.1.1
CATEGORIES= security
MASTER_SITES= http://www.foofus.net/~jmk/tools/ \
http://redundancy.redundancy.org/mirror/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Speedy, massively parallel, modular, login brute-forcer
-OPTIONS_DEFINE= SVN PGSQL DOCS
+LIB_DEPENDS+= libssh2.so:${PORTSDIR}/security/libssh2
-LIB_DEPENDS+= ssh2:${PORTSDIR}/security/libssh2 \
- pcre:${PORTSDIR}/devel/pcre
+BROKEN_ia64= Does not build on ia64
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-module-ncp=no --enable-module-afp=no
-MAN1= medusa.1
-
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= SVN PGSQL DOCS
+OPTIONS_SUB= yes
-.if ${ARCH} == "ia64"
-BROKEN= Does not build on ia64
-.endif
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSVN}
-PLIST_SUB+= SVN=""
-LIB_DEPENDS+= svn_client-1:${PORTSDIR}/devel/subversion
+LIB_DEPENDS+= libsvn_client-1.so:${PORTSDIR}/devel/subversion
CFLAGS+= -I${LOCALBASE}/include/subversion-1 -I${LOCALBASE}/include/apr-1
.else
CONFIGURE_ARGS+= --enable-module-svn=no
-PLIST_SUB+= SVN="@comment "
.endif
.if ${PORT_OPTIONS:MPGSQL}
-PLIST_SUB+= POSTGRESQL=""
USE_PGSQL= yes
CONFIGURE_ARGS+= --enable-module-postgres
.else
CONFIGURE_ARGS+= --enable-module-postgres=no
-PLIST_SUB+= POSTGRESQL="@comment "
.endif
post-install:
- ${MKDIR} ${PREFIX}/share/zsh/site-functions
- ${INSTALL_DATA} ${WRKSRC}/misc/zsh/_medusa ${PREFIX}/share/zsh/site-functions/_medusa
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/zsh/site-functions
+ ${INSTALL_DATA} ${WRKSRC}/misc/zsh/_medusa \
+ ${STAGEDIR}${PREFIX}/share/zsh/site-functions/_medusa
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/*.html ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.html ${STAGEDIR}${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/medusa/distinfo b/security/medusa/distinfo
index dc6b421c6066..06d103a4d967 100644
--- a/security/medusa/distinfo
+++ b/security/medusa/distinfo
@@ -1,2 +1,2 @@
-SHA256 (medusa-2.1.tar.gz) = c025913f2adb46f6363403f1dba37a03155fefe338866e5ce249f765ce90617e
-SIZE (medusa-2.1.tar.gz) = 383741
+SHA256 (medusa-2.1.1.tar.gz) = c8f83f54f76f021f213007c1c83e659f30dd16de84046df2b50e3db2bb6a7ef2
+SIZE (medusa-2.1.1.tar.gz) = 383424
diff --git a/security/medusa/files/patch-src_medusa.c b/security/medusa/files/patch-src_medusa.c
new file mode 100644
index 000000000000..0653950bbae4
--- /dev/null
+++ b/security/medusa/files/patch-src_medusa.c
@@ -0,0 +1,54 @@
+--- src/medusa.c.orig 2012-03-01 17:39:35.000000000 +0000
++++ src/medusa.c
+@@ -1438,6 +1438,7 @@ int setPassResult(sLogin *_psLogin, char
+ }
+
+ pthread_mutex_unlock(&_psLogin->psServer->ptmMutex);
++ return 0;
+ }
+
+
+@@ -1497,6 +1498,7 @@ int addMissedCredSet(sLogin *_psLogin, s
+ _psLogin->psServer->iCredentialsMissed++;
+
+ pthread_mutex_unlock(&_psLogin->psServer->ptmMutex);
++ return 0;
+ }
+
+
+@@ -1567,7 +1569,7 @@ void *startLoginThreadPool(void *arg)
+ if (errcode != 0)
+ {
+ writeError(ERR_CRITICAL, "Failed to resolve hostname: %s - %s", _psServer->psHost->pHost, gai_strerror(errcode));
+- return;
++ return NULL;
+ }
+
+ if (res->ai_next != NULL)
+@@ -1609,7 +1611,7 @@ void *startLoginThreadPool(void *arg)
+ if ( thr_pool_queue(login_pool, startModule, (void *) &modParams[iLoginId]) < 0 )
+ {
+ writeError(ERR_CRITICAL, "Failed to add module launch task to login thread pool for server queue: %d.", _psServer->iId);
+- return;
++ return NULL;
+ }
+ }
+
+@@ -1645,7 +1647,7 @@ void *startLoginThreadPool(void *arg)
+ if ( thr_pool_queue(login_pool, startModule, (void *) &modParams[iLoginId]) < 0 )
+ {
+ writeError(ERR_CRITICAL, "Failed to add module launch task to login thread pool for server queue: %d.", _psServer->iId);
+- return;
++ return NULL;
+ }
+
+ /* wait for login thread pool to finish */
+@@ -1675,7 +1677,7 @@ void *startLoginThreadPool(void *arg)
+
+ free(_psServer->pHostIP);
+
+- return;
++ return NULL;
+ }
+
+
diff --git a/security/medusa/pkg-descr b/security/medusa/pkg-descr
index abcd53a7e8a8..6a2a37565538 100644
--- a/security/medusa/pkg-descr
+++ b/security/medusa/pkg-descr
@@ -2,4 +2,4 @@ Medusa is intended to be a speedy, massively parallel, modular, login
brute-forcer. The goal is to support as many services which allow remote
authentication as possible.
-WWW: http://www.foofus.net/jmk/medusa/medusa.html
+WWW: http://www.foofus.net/jmk/medusa/medusa.html
diff --git a/security/medusa/pkg-plist b/security/medusa/pkg-plist
index 1ef7cd0c5430..fcdff64838bf 100644
--- a/security/medusa/pkg-plist
+++ b/security/medusa/pkg-plist
@@ -1,29 +1,29 @@
bin/medusa
-lib/medusa/modules/telnet.mod
-lib/medusa/modules/smbnt.mod
+lib/medusa/modules/cvs.mod
+lib/medusa/modules/ftp.mod
lib/medusa/modules/http.mod
-lib/medusa/modules/ssh.mod
+lib/medusa/modules/imap.mod
lib/medusa/modules/mssql.mod
-lib/medusa/modules/pop3.mod
lib/medusa/modules/mysql.mod
-lib/medusa/modules/pcanywhere.mod
-lib/medusa/modules/ftp.mod
-lib/medusa/modules/imap.mod
lib/medusa/modules/nntp.mod
-lib/medusa/modules/rsh.mod
+lib/medusa/modules/pcanywhere.mod
+%%PGSQL%%lib/medusa/modules/postgres.mod
+lib/medusa/modules/pop3.mod
lib/medusa/modules/rexec.mod
-lib/medusa/modules/wrapper.mod
lib/medusa/modules/rlogin.mod
-lib/medusa/modules/vnc.mod
-%%POSTGRESQL%%lib/medusa/modules/postgres.mod
-lib/medusa/modules/cvs.mod
-lib/medusa/modules/vmauthd.mod
-lib/medusa/modules/snmp.mod
+lib/medusa/modules/rsh.mod
+lib/medusa/modules/smbnt.mod
lib/medusa/modules/smtp-vrfy.mod
lib/medusa/modules/smtp.mod
+lib/medusa/modules/snmp.mod
+lib/medusa/modules/ssh.mod
%%SVN%%lib/medusa/modules/svn.mod
+lib/medusa/modules/telnet.mod
+lib/medusa/modules/vmauthd.mod
+lib/medusa/modules/vnc.mod
lib/medusa/modules/web-form.mod
-share/zsh/site-functions/_medusa
+lib/medusa/modules/wrapper.mod
+man/man1/medusa.1.gz
%%PORTDOCS%%%%DOCSDIR%%/medusa-afp.html
%%PORTDOCS%%%%DOCSDIR%%/medusa-compare.html
%%PORTDOCS%%%%DOCSDIR%%/medusa-cvs.html
@@ -52,8 +52,9 @@ share/zsh/site-functions/_medusa
%%PORTDOCS%%%%DOCSDIR%%/medusa-web-form.html
%%PORTDOCS%%%%DOCSDIR%%/medusa-wrapper.html
%%PORTDOCS%%%%DOCSDIR%%/medusa.html
-@unexec [ -f %D/bin/zsh ] || rmdir %D/share/zsh/site-functions 2>/dev/null || true
+share/zsh/site-functions/_medusa
+@dirrmtry lib/medusa/modules
+@dirrmtry lib/medusa
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%
+@dirrmtry share/zsh/site-functions
@dirrmtry share/zsh
-@dirrm lib/medusa/modules
-@dirrm lib/medusa
-%%PORTDOCS%%@dirrm %%DOCSDIR%%