aboutsummaryrefslogtreecommitdiffstats
path: root/security/metasploit
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2008-04-06 16:58:21 +0800
committerstas <stas@FreeBSD.org>2008-04-06 16:58:21 +0800
commit6fbde8aaf51fc0bcaf991519b739b0592c98f740 (patch)
tree280ebf175af2693f172cb9dc5674fa73fb5992d3 /security/metasploit
parentf29755f74021d623e3671b29c948ead5c3e33715 (diff)
downloadfreebsd-ports-gnome-6fbde8aaf51fc0bcaf991519b739b0592c98f740.tar.gz
freebsd-ports-gnome-6fbde8aaf51fc0bcaf991519b739b0592c98f740.tar.zst
freebsd-ports-gnome-6fbde8aaf51fc0bcaf991519b739b0592c98f740.zip
- Add ruby 1.9 support
- Implement new knobs for gems and rake (these are included in ruby 1.9 distribution already). Also move gem bits from ruby-gems/Makefile.common to bsd.ruby.mk[1]. Now to depend on gems or rake you should define USE_RUBYGEMS/USE_RAKE accordingly. Also RAKE_BIN variable is provided for pointing to the right rake executable. - Rewrite RUBY_SCHEBANG in awk to eliminate build dependency on ruby. Discussed with: Jonathan Weiss <jw@innerewut.de> [1] (gems maintainer) Tested by: ports@
Diffstat (limited to 'security/metasploit')
-rw-r--r--security/metasploit/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/security/metasploit/Makefile b/security/metasploit/Makefile
index 429fa97a9c4f..b15c6890baad 100644
--- a/security/metasploit/Makefile
+++ b/security/metasploit/Makefile
@@ -15,7 +15,6 @@ MAINTAINER= onatan@gmail.com
COMMENT= Exploit-Framework for Penetration-Testing
RUN_DEPENDS= ${LOCALBASE}/bin/svn:${PORTSDIR}/devel/subversion \
- ${LOCALBASE}/bin/gem:${PORTSDIR}/devel/ruby-gems \
${LOCALBASE}/lib/ruby/gems/1.8/specifications/activerecord-1.15.6.gemspec:${PORTSDIR}/databases/rubygem-activerecord
SCRIPTS= msfcli msfconsole msfd msfencode msflicense msfopcode \
@@ -28,6 +27,10 @@ USE_RUBY= yes
.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+RUN_DEPENDS+= ${LOCALBASE}/bin/gem:${PORTSDIR}/devel/ruby-gems
+.endif
+
.if defined(WITH_MSFGUI)
RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/wxruby.so:${PORTSDIR}/x11-toolkits/ruby-wx
SCRIPTS+= msfgui