aboutsummaryrefslogtreecommitdiffstats
path: root/security/mindterm-binary/Makefile
diff options
context:
space:
mode:
authoralex <alex@FreeBSD.org>2000-09-23 01:06:17 +0800
committeralex <alex@FreeBSD.org>2000-09-23 01:06:17 +0800
commit98ab875770c1f14e8938dbe523ddf0fedd4e2ed7 (patch)
treed6ed9e744f5c10a40f774368fb3582791053afdd /security/mindterm-binary/Makefile
parentff76403fa111cf732ec70fb1b46abe27630704ff (diff)
downloadfreebsd-ports-gnome-98ab875770c1f14e8938dbe523ddf0fedd4e2ed7.tar.gz
freebsd-ports-gnome-98ab875770c1f14e8938dbe523ddf0fedd4e2ed7.tar.zst
freebsd-ports-gnome-98ab875770c1f14e8938dbe523ddf0fedd4e2ed7.zip
Add mindterm-binary, a binary-only port of mindterm, a featureful
SSH client (full VT220/xterm compatible!!) This is the binary-only version without a dependency to JDK but including a sample HTML-file instead (for use in webbrowsers).
Diffstat (limited to 'security/mindterm-binary/Makefile')
-rw-r--r--security/mindterm-binary/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/security/mindterm-binary/Makefile b/security/mindterm-binary/Makefile
new file mode 100644
index 000000000000..d50a2aa522bb
--- /dev/null
+++ b/security/mindterm-binary/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: mindterm-binary
+# Date created: 22 Sep 2000
+# Whom: alex@FreeBSD.org
+#
+# $FreeBSD$
+
+PORTNAME= mindterm-binary
+PORTVERSION= 1.2.1
+CATEGORIES= security
+MASTER_SITES= http://www.mindbright.se/mindterm/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= alex
+DISTNAME= mindtermbin-v121
+DISTFILES= mindterm-ssh.html ${EXTRACT_ONLY}
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+
+MAINTAINER= alex@FreeBSD.org
+
+USE_ZIP= yes
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+post-extract:
+ @${CP} ${DISTDIR}/mindterm-ssh.html ${WRKSRC}
+ @${MV} ${WRKSRC}/mindtermfull.jar ${WRKSRC}/mindterm.jar
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/java/mindterm
+ @${INSTALL_DATA} ${WRKSRC}/* ${PREFIX}/share/java/mindterm/
+
+.include <bsd.port.mk>