aboutsummaryrefslogtreecommitdiffstats
path: root/security/nacl
diff options
context:
space:
mode:
authorlx <lx@FreeBSD.org>2014-01-30 08:41:27 +0800
committerlx <lx@FreeBSD.org>2014-01-30 08:41:27 +0800
commitea492849148bcbcb302b89a0b77a272947899c1c (patch)
tree1d34e8e251ac10bb7a389efc38c2be5ed63e7a95 /security/nacl
parent34458a6ff78ec5fbe8a47cf47c11d9588204f2cf (diff)
downloadfreebsd-ports-gnome-ea492849148bcbcb302b89a0b77a272947899c1c.tar.gz
freebsd-ports-gnome-ea492849148bcbcb302b89a0b77a272947899c1c.tar.zst
freebsd-ports-gnome-ea492849148bcbcb302b89a0b77a272947899c1c.zip
Fix build on 10, honor C/CXX, and fix issue with curvecp.
Submitted by: fallout and Tim Newsham
Diffstat (limited to 'security/nacl')
-rw-r--r--security/nacl/Makefile2
-rw-r--r--security/nacl/files/patch-socket_udp.c13
2 files changed, 15 insertions, 0 deletions
diff --git a/security/nacl/Makefile b/security/nacl/Makefile
index eda1b0768b00..243a35dac939 100644
--- a/security/nacl/Makefile
+++ b/security/nacl/Makefile
@@ -26,6 +26,8 @@ HOSTNAME_CMD?= /bin/hostname -s
post-patch:
@${REINPLACE_CMD} -i -e "s/$$/ -fPIC/" ${WRKSRC}/okcompilers/c
+ @${REINPLACE_CMD} -i -e "s/gcc/${CC}/" ${WRKSRC}/okcompilers/c
+ @${REINPLACE_CMD} -i -e "s/c++/${CXX}/" ${WRKSRC}/okcompilers/cpp
pre-build:
${RM} -rf ${WRKSRC}/crypto_onetimeauth/poly1305/amd64
diff --git a/security/nacl/files/patch-socket_udp.c b/security/nacl/files/patch-socket_udp.c
new file mode 100644
index 000000000000..d8869aaf0ff2
--- /dev/null
+++ b/security/nacl/files/patch-socket_udp.c
@@ -0,0 +1,13 @@
+--- curvecp/socket_udp.c.orig 2014-01-29 15:34:07.000000000 -0800
++++ curvecp/socket_udp.c 2014-01-29 15:34:12.000000000 -0800
+@@ -6,6 +6,10 @@
+ #include "socket.h"
+ #include "blocking.h"
+
++#ifndef SOL_IP
++#define SOL_IP IPPROTO_IP /* FreeBSD requires protocol number */
++#endif
++
+ static void enable_bsd_fragmentation(int fd)
+ {
+ #ifdef IP_DONTFRAG