aboutsummaryrefslogtreecommitdiffstats
path: root/security/nessus-libraries
diff options
context:
space:
mode:
authorscheidell <scheidell@FreeBSD.org>2012-01-30 23:29:12 +0800
committerscheidell <scheidell@FreeBSD.org>2012-01-30 23:29:12 +0800
commit90539958ce30211e04b686a975395cad4fbc8c0e (patch)
treebe6c178d8dd5c505e025826b6f1ad76416acd9a2 /security/nessus-libraries
parentc87b07ae9e7f45c84a5924edc420de01c2f3066e (diff)
downloadfreebsd-ports-gnome-90539958ce30211e04b686a975395cad4fbc8c0e.tar.gz
freebsd-ports-gnome-90539958ce30211e04b686a975395cad4fbc8c0e.tar.zst
freebsd-ports-gnome-90539958ce30211e04b686a975395cad4fbc8c0e.zip
- Fix build due to libtool updates. [1]
- Edit makefile in nessus-libraries to remove bpf40 check, not needed on modern kernels [2] - Edit makefile in nessus-libraries allow package building [2] PR: ports/164595 Submitted by: Udo Schweigert <udo.schweigert@siemens.com> (maintainer) [1] Reviewed by: scheidell [2] Approved by: maintainer, gabor (implicit)
Diffstat (limited to 'security/nessus-libraries')
-rw-r--r--security/nessus-libraries/Makefile19
-rw-r--r--security/nessus-libraries/files/patch-libtool146
2 files changed, 148 insertions, 17 deletions
diff --git a/security/nessus-libraries/Makefile b/security/nessus-libraries/Makefile
index 142d5f033d93..f6f649b79de7 100644
--- a/security/nessus-libraries/Makefile
+++ b/security/nessus-libraries/Makefile
@@ -36,10 +36,10 @@ USE_LDCONFIG= YES
MAN1= nessus-config.1
-.if ! defined(NESSUS_CLIENT_ONLY)
+.if ! defined(NESSUS_CLIENT_ONLY) && ! defined(PACKAGE_BUILDING)
MANUAL_PACKAGE_BUILD= needs /dev/bpf which is not available in pointyhat jail
pre-configure:
- @if [ ! -c /dev/bpf1 ]; then \
+ @if [ ! -c /dev/bpf ]; then \
${ECHO} "********************************************************";\
${ECHO} "* W a r n i n g *";\
${ECHO} "* *";\
@@ -47,25 +47,10 @@ pre-configure:
${ECHO} "* To use nessus, your kernel must be rebuilt with bpf, *";\
${ECHO} "* and make bpf devices on /dev directory. *";\
${ECHO} "* *";\
- ${ECHO} "* Be sure to build as many bpf devices as you need. *";\
${ECHO} "* For more info on this read files/README.BPF *";\
${ECHO} "********************************************************";\
${FALSE}; \
fi
-.if ! defined(WITH_NESSUS_BPF_SHARE)
- @if [ ! -c /dev/bpf40 ]; then \
- ${ECHO} "********************************************************";\
- ${ECHO} "* W a r n i n g *";\
- ${ECHO} "* *";\
- ${ECHO} "* Nessus needs many bpf devices. If you can't rebuild *";\
- ${ECHO} "* your kernel with more than 40 bpf devices (as *";\
- ${ECHO} "* described in files/README.BPF) then build this port *";\
- ${ECHO} "* with \"make -DWITH_NESSUS_BPF_SHARE\" *";\
- ${ECHO} "* *";\
- ${ECHO} "********************************************************";\
- ${FALSE}; \
- fi
-.endif
.endif
.include <bsd.port.mk>
diff --git a/security/nessus-libraries/files/patch-libtool b/security/nessus-libraries/files/patch-libtool
new file mode 100644
index 000000000000..deae3e75c3a0
--- /dev/null
+++ b/security/nessus-libraries/files/patch-libtool
@@ -0,0 +1,146 @@
+--- work/nessus-libraries/libnessus/Makefile 2004-08-31 19:15:07.000000000 +0200
++++ libnessus/Makefile 2012-01-29 10:19:13.000000000 +0100
+@@ -22,85 +22,85 @@
+
+
+ getopt.o : getopt.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c getopt.c
++ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c getopt.c
+
+ getopt1.o : getopt1.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c getopt1.c
++ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c getopt1.c
+
+ plugutils.o : plugutils.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c plugutils.c
++ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c plugutils.c
+
+ resolve.o : resolve.c resolve.h
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c resolve.c
++ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c resolve.c
+
+ share_fd.o : share_fd.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c share_fd.c
++ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c share_fd.c
+
+ system.o : system.c system.h
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c system.c
++ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c system.c
+
+ arglists.o : arglists.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c arglists.c
++ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c arglists.c
+
+ network.o : network.c network.h
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c network.c
++ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c network.c
+
+ scanners_utils.o : scanners_utils.c scanners_utils.h
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c scanners_utils.c
++ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c scanners_utils.c
+
+ ftp_funcs.o : ftp_funcs.c ftp_funcs.h
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c ftp_funcs.c
++ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c ftp_funcs.c
+ www_funcs.o : www_funcs.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c www_funcs.c
++ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c www_funcs.c
+
+ pcap.o : pcap.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c pcap.c
++ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c pcap.c
+
+ hlst.o : hlst.c hlst.h
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c hlst.c
++ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c hlst.c
+
+ ptycall.o : ptycall.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c ptycall.c
++ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c ptycall.c
+
+ harglists.o : harglists.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c harglists.c
++ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c harglists.c
+
+ diff.o : diff.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c diff.c
++ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c diff.c
+
+ ids_send.o : ids_send.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c ids_send.c
++ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c ids_send.c
+
+ bpf_share.o: bpf_share.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -DNESSUS_STATE_DIR=\"$(localstatedir)\" -c bpf_share.c
++ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -DNESSUS_STATE_DIR=\"$(localstatedir)\" -c bpf_share.c
+
+ rand.o: rand.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c rand.c
++ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c rand.c
+
+ popen.o: popen.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c popen.c
++ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c popen.c
+
+ services.o: services.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -DNESSUS_STATE_DIR=\"$(localstatedir)\" -c services.c
++ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -DNESSUS_STATE_DIR=\"$(localstatedir)\" -c services.c
+
+ services1.o: services1.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -DNESSUS_STATE_DIR=\"$(localstatedir)\" -DCONF_DIR=\"$(sysconfdir)\" -c services1.c
++ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -DNESSUS_STATE_DIR=\"$(localstatedir)\" -DCONF_DIR=\"$(sysconfdir)\" -c services1.c
+
+ proctitle.o: proctitle.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c proctitle.c
++ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c proctitle.c
+
+ store.o: store.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -DNESSUS_STATE_DIR=\"$(localstatedir)\" -c store.c
++ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -DNESSUS_STATE_DIR=\"$(localstatedir)\" -c store.c
+
+
+ kb.o: kb.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c kb.c
++ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c kb.c
+
+
+ snprintf.o : snprintf.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c snprintf.c
++ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c snprintf.c
+ libnessus.la: $(OBJS)
+- $(LIBTOOL) $(CC) -o libnessus.la $(LO_OBJS) -rpath ${libdir} \
++ $(LIBTOOL) --mode link $(CC) -o libnessus.la $(LO_OBJS) -rpath ${libdir} \
+ -version-info ${PACKAGE_VERSION}
+
+ install : libnessus.la
+--- work/nessus-libraries/libhosts_gatherer/Makefile 2003-04-07 04:06:49.000000000 +0200
++++ libhosts_gatherer/Makefile 2012-01-29 10:19:27.000000000 +0100
+@@ -22,7 +22,7 @@
+ $(LIBTOOL) --finish $(DESTDIR)${libdir}
+
+ libhosts_gatherer.la : $(OBJS)
+- $(LIBTOOL) $(CC) -o libhosts_gatherer.la $(LO_OBJS) -rpath ${libdir} \
++ $(LIBTOOL) --mode link $(CC) -o libhosts_gatherer.la $(LO_OBJS) -rpath ${libdir} \
+ -version-info ${PACKAGE_VERSION}
+
+ hg_utils.o : hg_utils.h hosts_gatherer.h hg_utils.c
+--- work/nessus-libraries/libpcap-nessus/Makefile.in.orig 2004-01-08 17:12:55.000000000 +0100
++++ libpcap-nessus/Makefile.in 2012-01-29 10:22:47.000000000 +0100
+@@ -31,7 +31,7 @@
+ # You shouldn't need to edit anything below.
+ #
+
+-COMPILE = $(LIBTOOL) $(CC)
++COMPILE = $(LIBTOOL) --mode compile $(CC)
+ CCOPT = @V_CCOPT@
+ INCLS = -I. @V_INCLS@ -I../../include
+ ### Solaris make does not like += (jordan)
+@@ -89,7 +89,7 @@
+
+ libpcap-nessus.la: $(OBJ)
+ @rm -f $@
+- $(LIBTOOL) $(CC) -o libpcap-nessus.la $(LO_OBJ) -rpath ${libdir} \
++ $(LIBTOOL) --mode link $(CC) -o libpcap-nessus.la $(LO_OBJ) -rpath ${libdir} \
+ -version-info ${PACKAGE_VERSION}
+
+ scanner.c: $(srcdir)/scanner.l