aboutsummaryrefslogtreecommitdiffstats
path: root/security/nettle/Makefile
diff options
context:
space:
mode:
authorsergei <sergei@FreeBSD.org>2003-10-30 05:41:31 +0800
committersergei <sergei@FreeBSD.org>2003-10-30 05:41:31 +0800
commitb9b7c5b674c3c4bf4d27646e54d9574e420b5dbe (patch)
treea40f815ced32afbc94d26afe891c0e75fb4025ad /security/nettle/Makefile
parent5403d32aaf64cf7a941a0f421398e40f4ef18318 (diff)
downloadfreebsd-ports-gnome-b9b7c5b674c3c4bf4d27646e54d9574e420b5dbe.tar.gz
freebsd-ports-gnome-b9b7c5b674c3c4bf4d27646e54d9574e420b5dbe.tar.zst
freebsd-ports-gnome-b9b7c5b674c3c4bf4d27646e54d9574e420b5dbe.zip
- Install shared library (mostly for Pike 7.5 crypto toolkit)
- Install documentation and examples - Utilize INFO PR: 58338 Submitted by: Xavier Beaudouin <kiwi@plonk.home.oav.net> Approved by: maintainer
Diffstat (limited to 'security/nettle/Makefile')
-rw-r--r--security/nettle/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/security/nettle/Makefile b/security/nettle/Makefile
index f6fb3929b209..40f0c810b755 100644
--- a/security/nettle/Makefile
+++ b/security/nettle/Makefile
@@ -8,6 +8,7 @@
PORTNAME= nettle
PORTVERSION= 1.7
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://www.lysator.liu.se/~nisse/archive/ \
ftp://ftp.lysator.liu.se/pub/security/lsh/
@@ -20,12 +21,25 @@ LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
USE_GMAKE= yes
USE_OPENSSL= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include"
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- MAKEINFO="makeinfo --no-split"
+CONFIGURE_ARGS= --enable-shared
LDFLAGS+= -L${LOCALBASE}/lib
+INSTALLS_SHLIB= yes
+
+DOCS= NEWS README TODO nettle.html
+EXAMPLES= examples/README examples/*.c examples/*.h
+INFO= nettle
post-extract:
@${RM} -f ${WRKSRC}/nettle.info*
+post-install:
+ @${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${EXAMPLES} ${EXAMPLESDIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
+
.include <bsd.port.mk>