aboutsummaryrefslogtreecommitdiffstats
path: root/security/nikto/Makefile
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2014-01-12 23:13:07 +0800
committerjohans <johans@FreeBSD.org>2014-01-12 23:13:07 +0800
commit5f3f1d79be1e4bd855cf96fc90177ef7f4ae9bf3 (patch)
tree4a1a9532454e0f4b95d1970dfc97c52b29563e65 /security/nikto/Makefile
parent14638d057261aada92bae3b352ee075ba6cb5efa (diff)
downloadfreebsd-ports-gnome-5f3f1d79be1e4bd855cf96fc90177ef7f4ae9bf3.tar.gz
freebsd-ports-gnome-5f3f1d79be1e4bd855cf96fc90177ef7f4ae9bf3.tar.zst
freebsd-ports-gnome-5f3f1d79be1e4bd855cf96fc90177ef7f4ae9bf3.zip
- Enable stage support
- Correct perl path - Bump PORTREVISION
Diffstat (limited to 'security/nikto/Makefile')
-rw-r--r--security/nikto/Makefile46
1 files changed, 17 insertions, 29 deletions
diff --git a/security/nikto/Makefile b/security/nikto/Makefile
index 80759193bc6d..faf14796177d 100644
--- a/security/nikto/Makefile
+++ b/security/nikto/Makefile
@@ -3,6 +3,7 @@
PORTNAME= nikto
PORTVERSION= 2.1.5
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= security www
MASTER_SITES= http://www.cirt.net/${PORTNAME}/ \
@@ -16,50 +17,37 @@ LICENSE= GPLv2
OPTIONS_DEFINE= SSLEAY DOCS
OPTIONS_DEFAULT=SSLEAY
SSLEAY_DESC= Use NET::SSLeay for ssl scanning
+SSLEAY_RUN_DEPENDS= p5-Net-SSLeay>0:${PORTSDIR}/security/p5-Net-SSLeay
NO_BUILD= yes
USE_BZIP2= yes
-USES= perl5
+USES= perl5 shebangfix
USE_PERL5= run
+SHEBANG_FILES= nikto.pl
-MAN1= nikto.1
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MSSLEAY}
-RUN_DEPENDS+= p5-Net-SSLeay>0:${PORTSDIR}/security/p5-Net-SSLeay
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e \
+post-patch: .SILENT
+ ${REINPLACE_CMD} -e \
's|/usr/local/bin/perl|${PERL}| ; \
s|/etc/nikto.conf|${PREFIX}/etc/nikto.conf|' ${WRKSRC}/nikto.pl
- @${REINPLACE_CMD} -Ee \
+ ${REINPLACE_CMD} -Ee \
's|# (EXECDIR=).*/nikto|\1${DATADIR}| ; \
s|# (DBDIR=).*/databases|\1${DATADIR}/databases| ; \
s|# (PLUGINDIR=).*/plugins|\1${DATADIR}/plugins| ; \
s|# (TEMPLATEDIR=).*/templates|\1${DATADIR}/templates| ; \
s|# (DOCDIR=).*/docs|\1${DOCSDIR}|' ${WRKSRC}/nikto.conf
-do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/nikto.pl ${PREFIX}/bin/nikto
- ${INSTALL_MAN} ${WRKSRC}/docs/nikto.1 ${PREFIX}/man/man1/nikto.1
- ${INSTALL_DATA} ${WRKSRC}/nikto.conf ${PREFIX}/etc/nikto.conf.sample
-.if !exists(${PREFIX}/etc/nikto.conf)
- (cd ${PREFIX}/etc && ${CP} -p nikto.conf.sample nikto.conf)
-.endif
- @${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/replay.pl ${DATADIR}
+do-install: .SILENT
+ ${INSTALL_SCRIPT} ${WRKSRC}/nikto.pl ${STAGEDIR}${PREFIX}/bin/nikto
+ ${INSTALL_MAN} ${WRKSRC}/docs/nikto.1 ${STAGEDIR}${PREFIX}/man/man1/nikto.1
+ ${INSTALL_DATA} ${WRKSRC}/nikto.conf ${STAGEDIR}${PREFIX}/etc/nikto.conf.sample
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/replay.pl ${STAGEDIR}${DATADIR}
.for i in databases plugins templates
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} ${i} ${DATADIR})
-.endfor
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
-.for i in CHANGES.txt LICENSE.txt nikto.dtd nikto_manual.html
- ${INSTALL_DATA} ${WRKSRC}/docs/${i} ${DOCSDIR}
+ cd ${WRKSRC}; ${COPYTREE_SHARE} ${i} ${STAGEDIR}${DATADIR}
.endfor
-.endif
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/docs; ${INSTALL_DATA} CHANGES.txt LICENSE.txt nikto.dtd \
+ nikto_manual.html ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>