aboutsummaryrefslogtreecommitdiffstats
path: root/security/nmap
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2011-06-04 05:10:32 +0800
committerohauer <ohauer@FreeBSD.org>2011-06-04 05:10:32 +0800
commit2784c47f60222a38ab46d17afb76ff4ada23d431 (patch)
tree07c18614c574a92559f1a9526b51ff396e20a3c3 /security/nmap
parentc0be15d566c07fadbf90e0588cf9043c7402c268 (diff)
downloadfreebsd-ports-gnome-2784c47f60222a38ab46d17afb76ff4ada23d431.tar.gz
freebsd-ports-gnome-2784c47f60222a38ab46d17afb76ff4ada23d431.tar.zst
freebsd-ports-gnome-2784c47f60222a38ab46d17afb76ff4ada23d431.zip
- add support for gcc from ports
PR: ports/156880 Submitted by: Zhihao Yuan <lichray _at_ gmail.com>
Diffstat (limited to 'security/nmap')
-rw-r--r--security/nmap/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/security/nmap/Makefile b/security/nmap/Makefile
index 8b7b31a2e43d..7c90da8841d2 100644
--- a/security/nmap/Makefile
+++ b/security/nmap/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nmap
PORTVERSION= 5.51
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security ipv6
MASTER_SITES= http://nmap.org/dist/ \
LOCAL/ohauer
@@ -32,6 +32,13 @@ CONFIGURE_ARGS= --without-localdirs \
--with-liblua=${LOCALBASE}
CONFIGURE_ENV= LUA_INCDIR="${LUA_INCDIR}" LUA_LIBDIR="${LUA_LIBDIR}"
+# fix for gcc from ports
+.if ${CC} != "cc"
+GCCLIBDIR_CMDS= ${CC} -print-file-name=libstdc++.so | ${SED} -e 's/libstdc++.so//'
+CONFIGURE_ARGS+=LDFLAGS="-L$$(${GCCLIBDIR_CMDS})"
+NDCC= true
+.endif
+
MANLANG= "" de es fr hr hu it jp pl pt_BR pt_PT ro ru sk zh
MAN1= nmap.1
MAN1_EN= ncat.1 nping.1
@@ -71,5 +78,8 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/${i} ${EXAMPLESDIR}
. endfor
.endif
+.if defined(NDCC)
+ @${ECHO_MSG} do not forget to adjust libnmap.conf
+.endif
.include <bsd.port.mk>