aboutsummaryrefslogtreecommitdiffstats
path: root/security/nmapsi4/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-01-31 21:43:17 +0800
committermiwi <miwi@FreeBSD.org>2010-01-31 21:43:17 +0800
commitc2b2c2efdf5c98aa98990c76d637a26b59495fff (patch)
tree4c8d7b86dbffa2fc9cf42eccc9013385fc14b734 /security/nmapsi4/Makefile
parentb1242ab206a3cf6dcdaea9900027abb2530b6489 (diff)
downloadfreebsd-ports-gnome-c2b2c2efdf5c98aa98990c76d637a26b59495fff.tar.gz
freebsd-ports-gnome-c2b2c2efdf5c98aa98990c76d637a26b59495fff.tar.zst
freebsd-ports-gnome-c2b2c2efdf5c98aa98990c76d637a26b59495fff.zip
NmapSi4 is a complete Qt-based Gui with the design goals to provide a complete
nmap interface for Users, in order to management all options of this powerful security net scanner! WWW: http://www.nmapsi4.org PR: ports/142118 Submitted by: Gvozdikov Veniamin <g.veniamin at googlemail.com>
Diffstat (limited to 'security/nmapsi4/Makefile')
-rw-r--r--security/nmapsi4/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/security/nmapsi4/Makefile b/security/nmapsi4/Makefile
new file mode 100644
index 000000000000..b1301fefa17c
--- /dev/null
+++ b/security/nmapsi4/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: nmapsi4
+# Date created: 2009-10-30
+# Whom: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nmapsi4
+PORTVERSION= 0.2
+CATEGORIES= security
+MASTER_SITES= GOOGLE_CODE
+DISTNAME= ${PORTNAME}-${PORTVERSION}-alpha3
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= GUI frontend for the nmap scanning utility
+
+RUN_DEPENDS= ${LOCALBASE}/bin/nmap:${PORTSDIR}/security/nmap
+
+USE_CMAKE= yes
+CMAKE_USE_PTHREAD= yes
+USE_QT_VER= 4
+QT_COMPONENTS= gui xml qmake_build uic_build moc_build rcc_build network linguist
+
+post-install:
+ ${CHMOD} 755 ${PREFIX}/bin/${PORTNAME}
+ ${CHMOD} 755 ${PREFIX}/bin/${PORTNAME}-logr
+
+.include <bsd.port.mk>