aboutsummaryrefslogtreecommitdiffstats
path: root/security/nss/files
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-03-19 14:35:22 +0800
committermarcus <marcus@FreeBSD.org>2004-03-19 14:35:22 +0800
commit261eb5b6368075375d29968890447a58a84a4738 (patch)
tree9f9725067c73fc7995d8344b6dd4640474098e47 /security/nss/files
parent3efe4ac07f626fad237d669055ca1c0f9aab378a (diff)
downloadfreebsd-ports-gnome-261eb5b6368075375d29968890447a58a84a4738.tar.gz
freebsd-ports-gnome-261eb5b6368075375d29968890447a58a84a4738.tar.zst
freebsd-ports-gnome-261eb5b6368075375d29968890447a58a84a4738.zip
Link this library symbolically so that it can be linked into executables
along with OpenSSL. Without this, there is a symbol conflict with MD5_Update() which can cause applications such as Evolution 1.5 to crash when Kerberos support is enabled. The longer-term goal is to configure Mozilla's internal NSS to be linked symbolically which should allow us to enable OpenSSL support in gnomevfs2.
Diffstat (limited to 'security/nss/files')
-rw-r--r--security/nss/files/patch-..::coreconf::FreeBSD.mk15
1 files changed, 9 insertions, 6 deletions
diff --git a/security/nss/files/patch-..::coreconf::FreeBSD.mk b/security/nss/files/patch-..::coreconf::FreeBSD.mk
index 215cc94a4a96..5c14081ba418 100644
--- a/security/nss/files/patch-..::coreconf::FreeBSD.mk
+++ b/security/nss/files/patch-..::coreconf::FreeBSD.mk
@@ -1,8 +1,5 @@
-
-$FreeBSD$
-
---- ../coreconf/FreeBSD.mk.orig Thu Mar 27 02:17:25 2003
-+++ ../coreconf/FreeBSD.mk Fri Apr 11 00:53:38 2003
+--- ../coreconf/FreeBSD.mk.orig Wed Mar 26 20:17:25 2003
++++ ../coreconf/FreeBSD.mk Fri Mar 19 01:23:30 2004
@@ -35,9 +35,9 @@
include $(CORE_DEPTH)/coreconf/UNIX.mk
@@ -34,7 +31,7 @@ $FreeBSD$
endif
ARCH = freebsd
-@@ -66,7 +68,7 @@
+@@ -66,12 +68,12 @@
MOZ_OBJFORMAT := $(shell test -x /usr/bin/objformat && /usr/bin/objformat || echo aout)
ifeq ($(MOZ_OBJFORMAT),elf)
@@ -43,3 +40,9 @@ $FreeBSD$
else
DLL_SUFFIX = so.1.0
endif
+
+-MKSHLIB = $(CC) $(DSO_LDOPTS)
++MKSHLIB = $(CC) -Wl,-Bsymbolic $(DSO_LDOPTS)
+ ifdef MAPFILE
+ # Add LD options to restrict exported symbols to those in the map file
+ endif