aboutsummaryrefslogtreecommitdiffstats
path: root/security/nss
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-04-18 09:29:33 +0800
committermarcus <marcus@FreeBSD.org>2004-04-18 09:29:33 +0800
commit12ecc8fd4f6a52d0f0a2959b56049111a0f7ba34 (patch)
tree6a42eaef642f342cd2d506f2053767e1f5414394 /security/nss
parentbb30152f682e556ff18c85c1aa0d780ffbeb2477 (diff)
downloadfreebsd-ports-gnome-12ecc8fd4f6a52d0f0a2959b56049111a0f7ba34.tar.gz
freebsd-ports-gnome-12ecc8fd4f6a52d0f0a2959b56049111a0f7ba34.tar.zst
freebsd-ports-gnome-12ecc8fd4f6a52d0f0a2959b56049111a0f7ba34.zip
Unbreak on ia64 and alpha by linking directly with libc.
Diffstat (limited to 'security/nss')
-rw-r--r--security/nss/Makefile4
-rw-r--r--security/nss/files/patch-..::coreconf::FreeBSD.mk8
2 files changed, 6 insertions, 6 deletions
diff --git a/security/nss/Makefile b/security/nss/Makefile
index 137d5b6ea2f5..99e0288a1047 100644
--- a/security/nss/Makefile
+++ b/security/nss/Makefile
@@ -40,10 +40,6 @@ CONFLICTS= btoa-5.* digest-* emboss-2.4.* oases-2.* p5-PAR-0.*
IGNORE= "core dumps on alpha during build"
.endif
-.if ${ARCH} == "alpha" || ${ARCH} == "ia64"
-BROKEN= "Does not compile on alpha or ia64"
-.endif
-
post-patch:
@${REINPLACE_CMD} -e "s|-pthread|${PTHREAD_LIBS}|g" \
${WRKSRC}/../../security/coreconf/FreeBSD.mk
diff --git a/security/nss/files/patch-..::coreconf::FreeBSD.mk b/security/nss/files/patch-..::coreconf::FreeBSD.mk
index 5c14081ba418..39398a72567b 100644
--- a/security/nss/files/patch-..::coreconf::FreeBSD.mk
+++ b/security/nss/files/patch-..::coreconf::FreeBSD.mk
@@ -1,5 +1,5 @@
--- ../coreconf/FreeBSD.mk.orig Wed Mar 26 20:17:25 2003
-+++ ../coreconf/FreeBSD.mk Fri Mar 19 01:23:30 2004
++++ ../coreconf/FreeBSD.mk Sat Apr 17 21:25:24 2004
@@ -35,9 +35,9 @@
include $(CORE_DEPTH)/coreconf/UNIX.mk
@@ -31,7 +31,7 @@
endif
ARCH = freebsd
-@@ -66,12 +68,12 @@
+@@ -66,12 +68,16 @@
MOZ_OBJFORMAT := $(shell test -x /usr/bin/objformat && /usr/bin/objformat || echo aout)
ifeq ($(MOZ_OBJFORMAT),elf)
@@ -42,7 +42,11 @@
endif
-MKSHLIB = $(CC) $(DSO_LDOPTS)
++ifneq (,$(filter alpha ia64,$(OS_TEST)))
++MKSHLIB = $(CC) -Wl,-Bsymbolic -lc $(DSO_LDOPTS)
++else
+MKSHLIB = $(CC) -Wl,-Bsymbolic $(DSO_LDOPTS)
++endif
ifdef MAPFILE
# Add LD options to restrict exported symbols to those in the map file
endif