aboutsummaryrefslogtreecommitdiffstats
path: root/security/opencdk/Makefile
diff options
context:
space:
mode:
authorsergei <sergei@FreeBSD.org>2004-03-10 13:24:59 +0800
committersergei <sergei@FreeBSD.org>2004-03-10 13:24:59 +0800
commit7488e8a24102bf2e09e51b4eeeb884785a70074c (patch)
treeac085d7a9970c3c4feac1a02cc94543466c1ed35 /security/opencdk/Makefile
parent393ea13f0a00dce834e57d75c2bf53d16dbad154 (diff)
downloadfreebsd-ports-gnome-7488e8a24102bf2e09e51b4eeeb884785a70074c.tar.gz
freebsd-ports-gnome-7488e8a24102bf2e09e51b4eeeb884785a70074c.tar.zst
freebsd-ports-gnome-7488e8a24102bf2e09e51b4eeeb884785a70074c.zip
- Update to 0.5.4
Forgotten by: sergei Reminded by: Herbert J. Skuhra <herbert.skuhra@gmx.at>
Diffstat (limited to 'security/opencdk/Makefile')
-rw-r--r--security/opencdk/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/security/opencdk/Makefile b/security/opencdk/Makefile
index f5df7dc31385..62b4d10e45b6 100644
--- a/security/opencdk/Makefile
+++ b/security/opencdk/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= opencdk
-PORTVERSION= 0.4.5
+PORTVERSION= 0.5.4
PORTEPOCH= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNUPG} \
@@ -18,7 +18,7 @@ MASTER_SITE_SUBDIR= alpha/gnutls/opencdk
MAINTAINER= sergei@FreeBSD.org
COMMENT= Open Crypto Development Kit
-LIB_DEPENDS= gcrypt.6:${PORTSDIR}/security/libgcrypt
+LIB_DEPENDS= gcrypt.10:${PORTSDIR}/security/libgcrypt-devel
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
@@ -26,11 +26,11 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-libgcrypt-prefix=${LOCALBASE}
USE_REINPLACE= yes
-DOCS= AUTHORS NEWS README THANKS
+DOCS= AUTHORS NEWS README THANKS doc/opencdk-api.html
post-patch:
-.for file in encrypt.c main.c misc.c
- ${REINPLACE_CMD} -e 's/<malloc.h>/<stdlib.h>/' ${WRKSRC}/src/${file}
+.for f in encrypt.c main.c misc.c
+ ${REINPLACE_CMD} -e 's/<malloc.h>/<stdlib.h>/' ${WRKSRC}/src/${f}
.endfor
post-install:
@@ -39,10 +39,7 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/tests/*.gpg ${EXAMPLESDIR}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for file in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
-.endfor
- ${INSTALL_DATA} ${WRKSRC}/doc/opencdk-api.html ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
.include <bsd.port.mk>