aboutsummaryrefslogtreecommitdiffstats
path: root/security/opensc
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2009-01-10 10:45:46 +0800
committermezz <mezz@FreeBSD.org>2009-01-10 10:45:46 +0800
commit867a335b88f91d457005fa0c7b3bb7c85c5fca14 (patch)
tree68af898c9a11dd756c516c49a6715cee75888e70 /security/opensc
parent6f64cd00171c29c1c7cdfb1e40393e23fc35151d (diff)
downloadfreebsd-ports-gnome-867a335b88f91d457005fa0c7b3bb7c85c5fca14.tar.gz
freebsd-ports-gnome-867a335b88f91d457005fa0c7b3bb7c85c5fca14.tar.zst
freebsd-ports-gnome-867a335b88f91d457005fa0c7b3bb7c85c5fca14.zip
Add a new framework for browser plugins, USE_WEBPLUGINS. It is for which foo
plugins support one of web browsers and can take care of plist (depend on how you use it) at the same time. I have written a complete document and even show how it works in the www/firefox/Makefile.webplugins so be sure to read in there. If there is anything that isn't clear in the document, please feel free to ask and I will try my best to improvement it. FYI: GNOME 2.24 depends on this, so it's coming. BTW: It's based on www/linux-mplayer-plugin/Makefile.npapi with heavy modified. Approved by: portmgr
Diffstat (limited to 'security/opensc')
-rw-r--r--security/opensc/Makefile7
-rw-r--r--security/opensc/pkg-plist3
2 files changed, 8 insertions, 2 deletions
diff --git a/security/opensc/Makefile b/security/opensc/Makefile
index b20f8a48321d..47dcbec7e5fd 100644
--- a/security/opensc/Makefile
+++ b/security/opensc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= opensc
PORTVERSION= 0.11.6
+PORTREVISION= 1
CATEGORIES= security devel
MASTER_SITES= http://www.opensc-project.org/files/${PORTNAME}/ \
http://www.opensc-project.org/files/${PORTNAME}/testing/
@@ -78,9 +79,13 @@ RUN_DEPENDS+= pinentry:${PORTSDIR}/${PINENTRY_PORT}
USE_XORG= x11
CONFIGURE_ARGS+=--enable-nsplugin \
--with-libassuan-prefix=${LOCALBASE} \
- --with-plugindir=${LOCALBASE}/lib/browser_plugins \
+ --with-plugindir=${WEBPLUGINS_DIR} \
--with-pinentry=${PINENTRY}
PLIST_SUB+= SIGNER=""
+
+USE_WEBPLUGINS= gecko*
+WEBPLUGINS_FILES=opensc-signer.so
+.include "${PORTSDIR}/www/firefox/Makefile.webplugins"
.else
PLIST_SUB+= SIGNER="@comment "
.endif
diff --git a/security/opensc/pkg-plist b/security/opensc/pkg-plist
index 3fb2bc0b9753..d06cf89bf29f 100644
--- a/security/opensc/pkg-plist
+++ b/security/opensc/pkg-plist
@@ -29,7 +29,7 @@ include/opensc/ui.h
libdata/pkgconfig/libopensc.pc
libdata/pkgconfig/libpkcs15init.pc
libdata/pkgconfig/libscconf.pc
-%%SIGNER%%lib/browser_plugins/opensc-signer.so
+%%SIGNER%%%%WEBPLUGINS_DIR%%/opensc-signer.so
%%SIGNER%%lib/opensc-signer.a
%%SIGNER%%lib/opensc-signer.la
%%SIGNER%%lib/opensc-signer.so
@@ -72,6 +72,7 @@ lib/pkcs11/pkcs11-spy.so
%%DATADIR%%/rutoken.profile
%%DATADIR%%/setcos.profile
%%DATADIR%%/starcos.profile
+%%SIGNER%%@dirrmtry %%WEBPLUGINS_DIR%%
@dirrm include/opensc
@dirrm lib/pkcs11
@dirrm %%DATADIR%%