aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssh-portable/Makefile
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2002-06-25 07:04:37 +0800
committerdinoex <dinoex@FreeBSD.org>2002-06-25 07:04:37 +0800
commit115f1e63d639f04fe09fde74414446e6dcd20f5b (patch)
tree4cced4f4cc07b625647045657c23dd13d3c1b62c /security/openssh-portable/Makefile
parentbacadca039ef6a2c74ba0ef0c95cf108eb3a0222 (diff)
downloadfreebsd-ports-gnome-115f1e63d639f04fe09fde74414446e6dcd20f5b.tar.gz
freebsd-ports-gnome-115f1e63d639f04fe09fde74414446e6dcd20f5b.tar.zst
freebsd-ports-gnome-115f1e63d639f04fe09fde74414446e6dcd20f5b.zip
Create user for privsep
Diffstat (limited to 'security/openssh-portable/Makefile')
-rw-r--r--security/openssh-portable/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index bb678422843a..2640cf594d1c 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openssh
PORTVERSION= 3.3p1
+PORTREVISION= 1
CATEGORIES= security ipv6
MASTER_SITES= ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
ftp://ftp.op.net/pub/OpenBSD/OpenSSH/portable/ \
@@ -23,6 +24,7 @@ MAN8= sftp-server.8 sshd.8 ssh-keysign.8
CRYPTOLIBS= -L${OPENSSLLIB} -lcrypto
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --prefix=${PREFIX} --with-md5-passwords
+CONFIGURE_ARGS+= --with-privsep-path=${PREFIX}/empty
CLEAN= etc/ssh_config etc/sshd_config etc/moduli \
etc/ssh_host_key etc/ssh_host_key.pub \
etc/ssh_host_dsa_key etc/ssh_host_dsa_key.pub \
@@ -78,6 +80,12 @@ pre-configure:
(cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOCONF_ENV} ${AUTOHEADER})
.endif
+pre-install:
+ if ! pw groupshow sshd; then pw groupadd sshd -g 22; fi
+ if ! pw usershow sshd; then pw useradd sshd -g sshd -u 22 \
+ -h - -d ${PREFIX}/empty -s /nonexistent -c "sshd privilege separation"; fi
+ ${MKDIR} ${PREFIX}/empty
+
post-install:
@${CAT} ${PKGMESSAGE}