aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssh-portable/Makefile
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2002-06-25 12:59:10 +0800
committerdinoex <dinoex@FreeBSD.org>2002-06-25 12:59:10 +0800
commit18656ffd4ea6b81b876bed49acb11ce6333f0487 (patch)
tree24a1fac3ceca67854ffd66a1bc450d129d995627 /security/openssh-portable/Makefile
parent48b85a6bada06bdf4af6da48fef83f0fa2fb20e4 (diff)
downloadfreebsd-ports-gnome-18656ffd4ea6b81b876bed49acb11ce6333f0487.tar.gz
freebsd-ports-gnome-18656ffd4ea6b81b876bed49acb11ce6333f0487.tar.zst
freebsd-ports-gnome-18656ffd4ea6b81b876bed49acb11ce6333f0487.zip
change --with-privsep-path if OPENSSH_OVERWRITE_BASE is in effect.
Submitted by: brad@brad-x.com
Diffstat (limited to 'security/openssh-portable/Makefile')
-rw-r--r--security/openssh-portable/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index 2640cf594d1c..204b61faec5f 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -24,7 +24,6 @@ MAN8= sftp-server.8 sshd.8 ssh-keysign.8
CRYPTOLIBS= -L${OPENSSLLIB} -lcrypto
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --prefix=${PREFIX} --with-md5-passwords
-CONFIGURE_ARGS+= --with-privsep-path=${PREFIX}/empty
CLEAN= etc/ssh_config etc/sshd_config etc/moduli \
etc/ssh_host_key etc/ssh_host_key.pub \
etc/ssh_host_dsa_key etc/ssh_host_dsa_key.pub \
@@ -49,7 +48,11 @@ PREFIX= /usr
MANPREFIX= ${PREFIX}/share
CONFIGURE_ARGS+= --mandir=${MANPREFIX}/man \
--sysconfdir=/etc/ssh --localstatedir=/var
+EMPTYDIR= ${PREFIX}/empty
+.else
+EMPTYDIR= /var/empty
.endif
+CONFIGURE_ARGS+= --with-privsep-path=${EMPTYDIR}
.if defined(BATCH)
EXTRA_PATCHES+= ${FILESDIR}/batch.patch
@@ -81,10 +84,10 @@ pre-configure:
.endif
pre-install:
+ -${MKDIR} ${EMPTYDIR}
if ! pw groupshow sshd; then pw groupadd sshd -g 22; fi
if ! pw usershow sshd; then pw useradd sshd -g sshd -u 22 \
- -h - -d ${PREFIX}/empty -s /nonexistent -c "sshd privilege separation"; fi
- ${MKDIR} ${PREFIX}/empty
+ -h - -d ${EMPTYDIR} -s /nonexistent -c "sshd privilege separation"; fi
post-install:
@${CAT} ${PKGMESSAGE}