aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssh-portable/Makefile
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2007-08-30 23:40:39 +0800
committermnag <mnag@FreeBSD.org>2007-08-30 23:40:39 +0800
commit1da21e4d4cfed05242658b0c3020d0d41c6729bd (patch)
tree99d8c973bf331874f4caf099e7b6702144c0d6f4 /security/openssh-portable/Makefile
parentbbb1d27826d1c34d038cbd122cf084e95bc19de6 (diff)
downloadfreebsd-ports-gnome-1da21e4d4cfed05242658b0c3020d0d41c6729bd.tar.gz
freebsd-ports-gnome-1da21e4d4cfed05242658b0c3020d0d41c6729bd.tar.zst
freebsd-ports-gnome-1da21e4d4cfed05242658b0c3020d0d41c6729bd.zip
- Enable ssl-engine
- Update gsskex patch to 4.6p1-gsskex-20070312 - Update lpk patch to 4.6p1-0.3.9 - Update hpn patch to 4.6p1-hpn12v17 - Fix challenge-response issue - Bump PORTREVISION Reported by: Stefan Lambrev [1], ale@ [1]
Diffstat (limited to 'security/openssh-portable/Makefile')
-rw-r--r--security/openssh-portable/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index 8e57e2c36dcb..02efd78bcdaa 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openssh
DISTVERSION= 4.6p1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= security ipv6
MASTER_SITES= ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%SUBDIR%/ \
@@ -41,8 +42,8 @@ USE_OPENSSL= yes
USE_PERL5_BUILD= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --prefix=${PREFIX} \
- --with-md5-passwords --without-zlib-version-check
+CONFIGURE_ARGS= --prefix=${PREFIX} --with-md5-passwords \
+ --without-zlib-version-check --with-ssl-engine
PRECIOUS= ssh_config sshd_config ssh_host_key ssh_host_key.pub \
ssh_host_rsa_key ssh_host_rsa_key.pub ssh_host_dsa_key \
ssh_host_dsa_key.pub
@@ -100,7 +101,8 @@ CONFIGURE_ARGS+= --disable-suid-ssh
.if defined(KRB5_HOME) && exists(${KRB5_HOME}) || defined(WITH_GSSAPI)
.if defined(WITH_KERB_GSSAPI)
PATCH_DIST_STRIP= -p0
-EXTRA_PATCHES+= ${FILESDIR}/openssh-4.5p1-gsskex-20061220.patch
+PATCH_SITES+= http://www.sxw.org.uk/computing/patches/
+PATCHFILES+= openssh-4.6p1-gsskex-20070312.patch
.endif
PORTABLE_SUFFIX= # empty
GSSAPI_SUFFIX= -gssapi
@@ -145,14 +147,14 @@ BROKEN= HPN and LPK patches are incompatible
.if defined(WITH_HPN)
PATCH_DIST_STRIP= -p1
PATCH_SITES+= http://www.psc.edu/networking/projects/hpn-ssh/
-PATCHFILES+= openssh-4.6p1-hpn12v16.diff.gz
+PATCHFILES+= openssh-4.6p1-hpn12v17.diff.gz
.endif
# See http://dev.inversepath.com/trac/openssh-lpk
.if defined(WITH_LPK)
-PATCH_DIST_STRIP= -p1
+PATCH_DIST_STRIP= -p2
PATCH_SITES+= http://dev.inversepath.com/openssh-lpk/
-PATCHFILES+= openssh-lpk-4.5p1-0.3.8.patch
+PATCHFILES+= openssh-lpk-4.6p1-0.3.9.patch
USE_OPENLDAP= yes
CPPFLAGS+= "-I${LOCALBASE}/include -DWITH_LDAP_PUBKEY"
CONFIGURE_ARGS+= --with-libs='-lldap' --with-ldflags='-L/usr/local/lib' \