aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssh-portable/Makefile
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2004-02-26 13:56:07 +0800
committerdinoex <dinoex@FreeBSD.org>2004-02-26 13:56:07 +0800
commit59ab7e30786218db4ea827743664dabb5c708dc3 (patch)
tree27551e75c7ef3a98aae70e6911ecfce451175712 /security/openssh-portable/Makefile
parentd01b195b883a53ca5446ef6abc6483d6e82a6c31 (diff)
downloadfreebsd-ports-gnome-59ab7e30786218db4ea827743664dabb5c708dc3.tar.gz
freebsd-ports-gnome-59ab7e30786218db4ea827743664dabb5c708dc3.tar.zst
freebsd-ports-gnome-59ab7e30786218db4ea827743664dabb5c708dc3.zip
- add SIZE
Diffstat (limited to 'security/openssh-portable/Makefile')
-rw-r--r--security/openssh-portable/Makefile32
1 files changed, 16 insertions, 16 deletions
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index 356201652c55..5589503372f9 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -45,6 +45,22 @@ CONFIGURE_ARGS+= --with-tcp-wrappers
CONFIGURE_ARGS+= --disable-suid-ssh
.endif
+.if defined(KRB5_HOME) && exists(${KRB5_HOME})
+PKGNAMESUFFIX= -gssapi
+CONFLICTS+= openssh-portable-*
+CONFIGURE_ARGS+= --with-kerberos5=${KRB5_HOME}
+.else
+CONFLICTS+= openssh-gssapi-*
+.if !defined(WITHOUT_KERBEROS) && exists(/usr/include/krb5.h)
+CONFIGURE_ARGS+= --with-kerberos5
+EXTRA_PATCHES+= ${FILESDIR}/gss-serv.c.patch
+.endif
+.endif
+
+.if defined(BATCH)
+EXTRA_PATCHES+= ${FILESDIR}/batch.patch
+.endif
+
.if defined(OPENSSH_OVERWRITE_BASE)
WITH_OPENSSL_BASE= yes
PKGNAMESUFFIX= -overwrite-base
@@ -70,22 +86,6 @@ PLIST_SUB+= EMPTYDIR=${EMPTYDIR}
CONFIGURE_ARGS+= --sysconfdir=${ETCSSH}
CONFIGURE_ARGS+= --with-privsep-path=${EMPTYDIR}
-.if defined(BATCH)
-EXTRA_PATCHES+= ${FILESDIR}/batch.patch
-.endif
-
-.if defined(KRB5_HOME) && exists(${KRB5_HOME})
-PKGNAMESUFFIX= -gssapi
-CONFLICTS+= openssh-portable-*
-CONFIGURE_ARGS+= --with-kerberos5=${KRB5_HOME}
-.else
-CONFLICTS+= openssh-gssapi-*
-.if !defined(WITHOUT_KERBEROS) && exists(/usr/include/krb5.h)
-CONFIGURE_ARGS+= --with-kerberos5
-EXTRA_PATCHES+= ${FILESDIR}/gss-serv.c.patch
-.endif
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|-ldes||g' ${WRKSRC}/configure