aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssh-portable/Makefile
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2003-08-30 16:02:38 +0800
committerdinoex <dinoex@FreeBSD.org>2003-08-30 16:02:38 +0800
commit6e1f7db5593dbd0c55bbac980e01662edb154042 (patch)
tree5cb8474da5b86eb3e6c27578feba9f8ebc627333 /security/openssh-portable/Makefile
parent1ba8b98915954e5e936d913abdddc15bb258ab55 (diff)
downloadfreebsd-ports-gnome-6e1f7db5593dbd0c55bbac980e01662edb154042.tar.gz
freebsd-ports-gnome-6e1f7db5593dbd0c55bbac980e01662edb154042.tar.zst
freebsd-ports-gnome-6e1f7db5593dbd0c55bbac980e01662edb154042.zip
- use OPENSSLRPATH from bsd.openssl.mk
- strip CONFIGURE_ENV, LDFLAGS is set in bsd.openssl.mk
Diffstat (limited to 'security/openssh-portable/Makefile')
-rw-r--r--security/openssh-portable/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index 1aab176efbf3..ff5e4c9dbe14 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -23,7 +23,6 @@ MAN8= sftp-server.8 sshd.8 ssh-keysign.8
USE_OPENSSL= yes
CRYPTOLIBS= -L${OPENSSLLIB} -lcrypto
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= LDFLAGS=${LDFLAGS}
USE_PERL5_BUILD= yes
CONFIGURE_ARGS+= --prefix=${PREFIX} --with-md5-passwords
PRECIOUS= ssh_config sshd_config \
@@ -145,6 +144,8 @@ test:
CONFIGURE_ARGS+= --without-rpath
LDFLAGS=
.endif
+.else
+CONFIGURE_ARGS+= --with-rpath=${OPENSSLRPATH}
.endif
CONFIGURE_ARGS+= --with-ssl-dir=${OPENSSLBASE}