aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssh-portable/Makefile
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2004-08-18 19:35:53 +0800
committerdinoex <dinoex@FreeBSD.org>2004-08-18 19:35:53 +0800
commited67dbf2ef6cb36b1a16ebc9f1818f28652558cb (patch)
tree81743e5e6b631d1967298757bf02ee748bed4855 /security/openssh-portable/Makefile
parent81bcec16de4a612151e564a8a36b822109aafaac (diff)
downloadfreebsd-ports-gnome-ed67dbf2ef6cb36b1a16ebc9f1818f28652558cb.tar.gz
freebsd-ports-gnome-ed67dbf2ef6cb36b1a16ebc9f1818f28652558cb.tar.zst
freebsd-ports-gnome-ed67dbf2ef6cb36b1a16ebc9f1818f28652558cb.zip
- update to 3.9p1
set PORTVERSION 3.9.0.1 to avoid another bump of PORTEPOCH if 3.9.1p1 come out. - new option OPENSSH_SNAPSHOT
Diffstat (limited to 'security/openssh-portable/Makefile')
-rw-r--r--security/openssh-portable/Makefile26
1 files changed, 23 insertions, 3 deletions
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index ff013ce24442..0a642dd70d07 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -6,16 +6,33 @@
#
PORTNAME= openssh
-PORTVERSION= 3.8.1p1
+PORTVERSION= 3.9.0.1
+.if defined(OPENSSH_SNAPSHOT)
+PORTREVISION!= date -v-1d +%Y%m%d
+.endif
PORTEPOCH= 1
CATEGORIES= security ipv6
-MASTER_SITES= ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
- ftp://carroll.cac.psu.edu/pub/OpenBSD/OpenSSH/portable/
+MASTER_SITES= ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%SUBDIR%/ \
+ ftp://carroll.cac.psu.edu/pub/OpenBSD/OpenSSH/portable/%SUBDIR%/
PKGNAMESUFFIX?= ${PORTABLE_SUFFIX}${GSSAPI_SUFFIX}${BASE_SUFFIX}${PKGNAMESUFFIX2}
+MASTER_SITE_SUBDIR= ${MASTER_SITE_SUBDIR2}
+DISTNAME= ${DISTNAME2}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= The portable version of OpenBSD's OpenSSH
+OPENSSHVERSION= 3.9p1
+.if defined(OPENSSH_SNAPSHOT)
+MASTER_SITE_SUBDIR2= snapshot/
+DISTNAME2= ${PORTNAME}-SNAP-${PORTREVISION}
+NO_CHECKSUM= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+.else
+MASTER_SITE_SUBDIR2=
+DISTNAME2= ${PORTNAME}-${OPENSSHVERSION}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${OPENSSHVERSION}
+.endif
+
MAN1= sftp.1 ssh-add.1 ssh-agent.1 ssh-keygen.1 ssh-keyscan.1 scp.1 ssh.1
MLINKS= ssh.1 slogin.1
MAN5= ssh_config.5 sshd_config.5
@@ -130,6 +147,9 @@ test:
.include <bsd.port.pre.mk>
+SUDO?=
+MAKE_ENV+= SUDO="${SUDO}"
+
.if defined(KRB5_HOME) && exists(${KRB5_HOME}) || defined(WITH_GSSAPI)
.if ${OPENSSLBASE} == "/usr"
CONFIGURE_ARGS+= --without-rpath