aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssh-portable
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2006-02-08 04:04:25 +0800
committermnag <mnag@FreeBSD.org>2006-02-08 04:04:25 +0800
commit7d34d2823dc6789ac932c66b9ab495acb603d582 (patch)
tree17bb70b2bb494f21949f6090edc8f1744d2b4d02 /security/openssh-portable
parentb53471075a1b7e06466cad8a6f5d663c29b368eb (diff)
downloadfreebsd-ports-gnome-7d34d2823dc6789ac932c66b9ab495acb603d582.tar.gz
freebsd-ports-gnome-7d34d2823dc6789ac932c66b9ab495acb603d582.tar.zst
freebsd-ports-gnome-7d34d2823dc6789ac932c66b9ab495acb603d582.zip
- Reorganize Makefile in preparation to update to 4.3p1
- Add one http in MASTER_SITES - Update WWW
Diffstat (limited to 'security/openssh-portable')
-rw-r--r--security/openssh-portable/Makefile147
-rw-r--r--security/openssh-portable/pkg-descr2
2 files changed, 75 insertions, 74 deletions
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index 5d2ea6d0c994..8027865201e1 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -7,16 +7,14 @@
PORTNAME= openssh
PORTVERSION= 4.2.0.0
-.if defined(OPENSSH_SNAPSHOT)
-PORTREVISION!= date -v-1d +%Y%m%d
-.endif
PORTEPOCH= 1
CATEGORIES= security ipv6
MASTER_SITES= ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%SUBDIR%/ \
- ftp://carroll.cac.psu.edu/pub/OpenBSD/OpenSSH/portable/%SUBDIR%/
-MASTER_SITE_SUBDIR= ${MASTER_SITE_SUBDIR2}
-PKGNAMESUFFIX?= ${PORTABLE_SUFFIX}${GSSAPI_SUFFIX}${BASE_SUFFIX}${PKGNAMESUFFIX2}
-DISTNAME= ${DISTNAME2}
+ ftp://carroll.cac.psu.edu/pub/OpenBSD/OpenSSH/portable/%SUBDIR%/ \
+ http://mirror.mcs.anl.gov/openssh/portable/%SUBDIR%/
+MASTER_SITE_SUBDIR= # empty
+PKGNAMESUFFIX?= ${PORTABLE_SUFFIX}${GSSAPI_SUFFIX}${BASE_SUFFIX}
+DISTNAME= # empty
MAINTAINER= mnag@FreeBSD.org
COMMENT= The portable version of OpenBSD's OpenSSH
@@ -24,14 +22,14 @@ COMMENT= The portable version of OpenBSD's OpenSSH
OPENSSHVERSION= 4.2p1
.if defined(OPENSSH_SNAPSHOT)
-MASTER_SITE_SUBDIR2= snapshot/
-DISTNAME2= ${PORTNAME}-SNAP-${PORTREVISION}
-NO_CHECKSUM= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}
+PORTREVISION!= date -v-1d +%Y%m%d
+NO_CHECKSUM= yes
+MASTER_SITE_SUBDIR+= snapshot
+DISTNAME+= ${PORTNAME}-SNAP-${PORTREVISION}
+WRKSRC= ${WRKDIR}/${PORTNAME}
.else
-MASTER_SITE_SUBDIR2=
-DISTNAME2= ${PORTNAME}-${OPENSSHVERSION}
-WRKSRC= ${WRKDIR}/${PORTNAME}-${OPENSSHVERSION}
+DISTNAME+= ${PORTNAME}-${OPENSSHVERSION}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${OPENSSHVERSION}
.endif
MAN1= sftp.1 ssh-add.1 ssh-agent.1 ssh-keygen.1 ssh-keyscan.1 scp.1 ssh.1
@@ -39,27 +37,29 @@ MLINKS= ssh.1 slogin.1
MAN5= ssh_config.5 sshd_config.5
MAN8= sftp-server.8 sshd.8 ssh-keysign.8
-CONFLICTS?= openssh-3.* ssh-1.* ssh2-3.*
-USE_OPENSSL= yes
-CRYPTOLIBS= -L${OPENSSLLIB} -lcrypto
-GNU_CONFIGURE= yes
-USE_REINPLACE= yes
+CONFLICTS?= openssh-3.* ssh-1.* ssh2-3.*
+
+USE_OPENSSL= yes
USE_PERL5_BUILD= yes
-CONFIGURE_ARGS+= --prefix=${PREFIX} --with-md5-passwords --without-zlib-version-check
-PRECIOUS= ssh_config sshd_config \
- ssh_host_key ssh_host_key.pub \
- ssh_host_rsa_key ssh_host_rsa_key.pub \
- ssh_host_dsa_key ssh_host_dsa_key.pub
-ETCOLD= ${PREFIX}/etc
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --prefix=${PREFIX} --with-md5-passwords \
+ --without-zlib-version-check
+PRECIOUS= ssh_config sshd_config ssh_host_key ssh_host_key.pub \
+ ssh_host_rsa_key ssh_host_rsa_key.pub ssh_host_dsa_key \
+ ssh_host_dsa_key.pub
+ETCOLD= ${PREFIX}/etc
PORTABLE_SUFFIX= -portable
-SUDO?=
+SUDO?= # empty
MAKE_ENV+= SUDO="${SUDO}"
OPTIONS= SUID_SSH "Enable suid SSH (Recommended off)" off \
GSSAPI "Enable GSSAPI support" off \
OPENSSH_CHROOT "Enable CHROOT support" off
+.include <bsd.port.pre.mk>
+
.if exists(/usr/include/security/pam_modules.h)
CONFIGURE_ARGS+= --with-pam
.endif
@@ -68,29 +68,28 @@ CONFIGURE_ARGS+= --with-pam
CONFIGURE_ARGS+= --with-tcp-wrappers
.endif
-.include <bsd.port.pre.mk>
-
.if !defined(WITH_SUID_SSH)
CONFIGURE_ARGS+= --disable-suid-ssh
.endif
.if defined(KRB5_HOME) && exists(${KRB5_HOME}) || defined(WITH_GSSAPI)
-PORTABLE_SUFFIX=
-GSSAPI_SUFFIX= -gssapi
-CONFLICTS+= openssh-portable-*
+PORTABLE_SUFFIX= # empty
+GSSAPI_SUFFIX= -gssapi
+CONFLICTS+= openssh-portable-*-[0-9]*
CONFIGURE_ARGS+= --with-kerberos5=${KRB5_HOME}
.if ${OPENSSLBASE} == "/usr"
CONFIGURE_ARGS+= --without-rpath
-LDFLAGS=
+LDFLAGS= # empty
.endif
.else
-CONFLICTS+= openssh-gssapi-*
+CONFLICTS+= openssh-gssapi-*-[0-9]*
CONFIGURE_ARGS+= --with-rpath=${OPENSSLRPATH}
.if !defined(WITHOUT_KERBEROS) && exists(/usr/include/krb5.h)
CONFIGURE_ARGS+= --with-kerberos5
EXTRA_PATCHES+= ${FILESDIR}/gss-serv.c.patch
.endif
.endif
+
.if ${OPENSSLBASE} != "/usr"
CONFIGURE_ARGS+= --with-ssl-dir=${OPENSSLBASE}
.endif
@@ -105,28 +104,28 @@ CFLAGS+= -DCHROOT
.if defined(OPENSSH_OVERWRITE_BASE)
WITH_OPENSSL_BASE= yes
-BASE_SUFFIX= -overwrite-base
-PREFIX= /usr
-MANPREFIX= ${PREFIX}/share
-CONFIGURE_ARGS+= --mandir=${MANPREFIX}/man --localstatedir=/var
-EMPTYDIR= /var/empty
-ETCSSH= /etc/ssh
-PLIST_SUB+= NOTBASE="@comment "
-PLIST_SUB+= BASE=""
-PKGMESSAGE= pkg-message.empty
+BASE_SUFFIX= -overwrite-base
+CONFIGURE_ARGS+= --mandir=${PREFIX}/share/man --localstatedir=/var
+EMPTYDIR= /var/empty
+PREFIX= /usr
+ETCSSH= /etc/ssh
+PLIST_SUB+= NOTBASE="@comment "
+PLIST_SUB+= BASE=""
+PKGMESSAGE= pkg-message.empty
.else
.if exists(/var/empty)
-EMPTYDIR= /var/empty
+EMPTYDIR= /var/empty
.else
-EMPTYDIR= ${PREFIX}/empty
+EMPTYDIR= ${PREFIX}/empty
.endif
-ETCSSH= ${PREFIX}/etc/ssh
-PLIST_SUB+= NOTBASE=""
-PLIST_SUB+= BASE="@comment "
+ETCSSH= ${PREFIX}/etc/ssh
+PLIST_SUB+= NOTBASE=""
+PLIST_SUB+= BASE="@comment "
.endif
-PLIST_SUB+= EMPTYDIR=${EMPTYDIR}
-CONFIGURE_ARGS+= --sysconfdir=${ETCSSH}
-CONFIGURE_ARGS+= --with-privsep-path=${EMPTYDIR}
+
+# After all
+PLIST_SUB+= EMPTYDIR="${EMPTYDIR}"
+CONFIGURE_ARGS+= --sysconfdir=${ETCSSH} --with-privsep-path=${EMPTYDIR}
post-patch:
@${REINPLACE_CMD} -e 's|-ldes|-lcrypto|g' ${WRKSRC}/configure
@@ -136,35 +135,37 @@ post-configure:
${FILESDIR}/sshd.sh > ${WRKSRC}/sshd.sh
pre-install:
-. if defined(OPENSSH_OVERWRITE_BASE)
- -${MKDIR} ${EMPTYDIR}
-. else
- -${MKDIR} ${PREFIX}/empty
-. endif
+.if defined(OPENSSH_OVERWRITE_BASE)
+ @${MKDIR} ${EMPTYDIR}
+.else
+ @${MKDIR} ${PREFIX}/empty
+.endif
if ! pw groupshow sshd; then pw groupadd sshd -g 22; fi
if ! pw usershow sshd; then pw useradd sshd -g sshd -u 22 \
-h - -d ${EMPTYDIR} -s /nonexistent -c "sshd privilege separation"; fi
- -@[ ! -d ${ETCSSH} ] && ${MKDIR} ${ETCSSH}
-. for i in ${PRECIOUS}
- -@[ -f ${ETCOLD}/${i} ] && [ ! -f ${ETCSSH}/${i} ] && \
- ${ECHO_MSG} ">> Linking ${ETCSSH}/${i} from old layout." && \
- ${LN} ${ETCOLD}/${i} ${ETCSSH}/${i}
-. endfor
+.if !exists(${ETCSSH})
+ @${MKDIR} ${ETCSSH}
+.endif
+.for i in ${PRECIOUS}
+.if exists(${ETCOLD}/${i}) && !exists(${ETCSSH}/${i})
+ @${ECHO_MSG} "==> Linking ${ETCSSH}/${i} from old layout."
+ ${LN} ${ETCOLD}/${i} ${ETCSSH}/${i}
+.endif
+.endfor
post-install:
-. if !defined(OPENSSH_OVERWRITE_BASE)
- ${INSTALL_SCRIPT} ${WRKSRC}/sshd.sh ${PREFIX}/etc/rc.d/sshd.sh.sample
-. endif
+.if !defined(OPENSSH_OVERWRITE_BASE)
+ ${INSTALL_SCRIPT} ${WRKSRC}/sshd.sh ${PREFIX}/etc/rc.d/sshd.sh.sample
+.endif
${INSTALL_DATA} -c ${WRKSRC}/ssh_config.out ${ETCSSH}/ssh_config-dist
${INSTALL_DATA} -c ${WRKSRC}/sshd_config.out ${ETCSSH}/sshd_config-dist
-. if !defined(OPENSSH_OVERWRITE_BASE)
- @${CAT} ${PKGMESSAGE}
-. endif
-
-test:
- (cd ${WRKSRC}/regress && ${SETENV} ${MAKE_ENV} \
- TEST_SHELL=/bin/sh \
- PATH=${WRKSRC}:${PREFIX}/bin:${PREFIX}/sbin:${PATH} \
- ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} )
+.if !defined(OPENSSH_OVERWRITE_BASE)
+ @${CAT} ${PKGMESSAGE}
+.endif
+
+test: build
+ (cd ${WRKSRC}/regress && ${SETENV} ${MAKE_ENV} TEST_SHELL=/bin/sh \
+ PATH=${WRKSRC}:${PREFIX}/bin:${PREFIX}/sbin:${PATH} \
+ ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS})
.include <bsd.port.post.mk>
diff --git a/security/openssh-portable/pkg-descr b/security/openssh-portable/pkg-descr
index 99ac07bfd209..58bd0e028500 100644
--- a/security/openssh-portable/pkg-descr
+++ b/security/openssh-portable/pkg-descr
@@ -12,4 +12,4 @@ are not synchronized. Portable releases are marked with a 'p' (e.g. 3.1p1).
The official OpenBSD source will never use the 'p' suffix, but will instead
increment the version number when they hit 'stable spots' in their development.
-WWW: http://www.openssh.com/portable.html
+WWW: http://www.openssh.org/portable.html