aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssh-portable
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2015-03-20 10:43:43 +0800
committerbdrewery <bdrewery@FreeBSD.org>2015-03-20 10:43:43 +0800
commitba62d7530d5d43bc3f48f7e88e69b32ff28107e7 (patch)
tree8b6f705af5cf33213a79a5b0dc33740eeb9d5f11 /security/openssh-portable
parent59c1fd2e6adb243d7d89cfabfaa7668c3681be25 (diff)
downloadfreebsd-ports-gnome-ba62d7530d5d43bc3f48f7e88e69b32ff28107e7.tar.gz
freebsd-ports-gnome-ba62d7530d5d43bc3f48f7e88e69b32ff28107e7.tar.zst
freebsd-ports-gnome-ba62d7530d5d43bc3f48f7e88e69b32ff28107e7.zip
Remove remnants of OVERWRITE_BASE which was removed in r376306
Diffstat (limited to 'security/openssh-portable')
-rw-r--r--security/openssh-portable/Makefile22
-rw-r--r--security/openssh-portable/pkg-plist12
2 files changed, 10 insertions, 24 deletions
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index ee19917d06d0..f917cf122390 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -54,7 +54,6 @@ AES_THREADED_DESC= Threaded AES-CTR
NONECIPHER_DESC= NONE Cipher support
OPTIONS_SUB= yes
-PLIST_SUB+= MANPREFIX=${MANPREFIX}
TCP_WRAPPERS_EXTRA_PATCHES=${FILESDIR}/extra-patch-tcpwrappers
@@ -189,24 +188,13 @@ EMPTYDIR= /var/empty
.if ${PORT_OPTIONS:MOVERWRITE_BASE} || defined(OPENSSH_OVERWRITE_BASE)
IGNORE= Overwrite base option is no longer supported.
-WITH_OPENSSL_BASE= yes
-CONFIGURE_ARGS+= --localstatedir=/var
-PREFIX= /usr
-NO_MTREE= yes
-ETCSSH= /etc/ssh
-USE_RCORDER= openssh
-PLIST_SUB+= NOTBASE="@comment "
-.else
-ETCSSH= ${PREFIX}/etc/ssh
-USE_RC_SUBR= openssh
-PLIST_SUB+= NOTBASE=""
.endif
+USE_RC_SUBR= openssh
PLIST_SUB+= BASEPREFIX="${PREFIX}"
# After all
-SUB_LIST+= ETCSSH="${ETCSSH}"
-CONFIGURE_ARGS+= --sysconfdir=${ETCSSH} --with-privsep-path=${EMPTYDIR}
+CONFIGURE_ARGS+= --sysconfdir=${ETCDIR} --with-privsep-path=${EMPTYDIR}
.if !empty(CONFIGURE_LIBS)
CONFIGURE_ARGS+= --with-libs='${CONFIGURE_LIBS}'
.endif
@@ -238,8 +226,10 @@ post-patch:
.endif
post-install:
- ${MV} ${STAGEDIR}${ETCSSH}/ssh_config ${STAGEDIR}${ETCSSH}/ssh_config.sample
- ${MV} ${STAGEDIR}${ETCSSH}/sshd_config ${STAGEDIR}${ETCSSH}/sshd_config.sample
+ ${MV} ${STAGEDIR}${ETCDIR}/ssh_config \
+ ${STAGEDIR}${ETCDIR}//ssh_config.sample
+ ${MV} ${STAGEDIR}${ETCDIR}/sshd_config \
+ ${STAGEDIR}${ETCDIR}/sshd_config.sample
.if ${PORT_OPTIONS:MHPN} || ${PORT_OPTIONS:MAES_THREADED} || ${PORT_OPTIONS:MNONECIPHER}
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/HPN-README ${STAGEDIR}${DOCSDIR}
diff --git a/security/openssh-portable/pkg-plist b/security/openssh-portable/pkg-plist
index eef6a9b5b185..50c23e426f02 100644
--- a/security/openssh-portable/pkg-plist
+++ b/security/openssh-portable/pkg-plist
@@ -7,21 +7,17 @@ bin/ssh-add
bin/ssh-agent
bin/ssh-keygen
bin/ssh-keyscan
-%%NOTBASE%%@exec if [ -f %D/etc/ssh_config -a ! -f %D/etc/ssh/ssh_config ]; then ln %D/etc/ssh_config %D/etc/ssh/ssh_config ; fi
-%%NOTBASE%%@exec if [ -f %D/etc/sshd_config -a ! -f %D/etc/ssh/sshd_config ]; then ln %D/etc/sshd_config %D/etc/ssh/sshd_config ; fi
-%%OVERWRITE_BASE%%@cwd /
-%%NOTBASE%%etc/ssh/moduli
+@exec if [ -f %D/etc/ssh_config -a ! -f %D/etc/ssh/ssh_config ]; then ln %D/etc/ssh_config %D/etc/ssh/ssh_config ; fi
+@exec if [ -f %D/etc/sshd_config -a ! -f %D/etc/ssh/sshd_config ]; then ln %D/etc/sshd_config %D/etc/ssh/sshd_config ; fi
+etc/ssh/moduli
@sample etc/ssh/ssh_config.sample
@sample etc/ssh/sshd_config.sample
-%%OVERWRITE_BASE%%@cwd %%BASEPREFIX%%
-%%NOTBASE%%%%X509%%@dirrmtry etc/ssh/ca
-%%NOTBASE%%@dirrmtry etc/ssh
+%%X509%%@dir etc/ssh/ca
@exec if [ -f %D/etc/ssh_host_ecdsa_key ] && grep -q DSA %D/etc/ssh_host_ecdsa_key; then echo; echo "\!/ Warning \!/"; echo; echo "Your %D/etc/ssh_host_ecdsa_key is not a valid ECDSA key. It is incorrectly"; echo "a DSA key due to a bug fixed in 2012 in the security/openssh-portable port."; echo; echo "Regenerate a proper one with: rm -f %D/etc/ssh_host_ecdsa_key*; service openssh restart"; echo; echo "Clients should not see any key change warning since the ECDSA was not valid and was not actually"; echo "used by the server."; echo; echo "\!/ Warning \!/"; fi
sbin/sshd
libexec/sftp-server
libexec/ssh-keysign
libexec/ssh-pkcs11-helper
-@cwd %%MANPREFIX%%
man/man1/sftp.1.gz
man/man1/ssh-add.1.gz
man/man1/ssh-agent.1.gz