aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssh-portable
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2006-06-13 00:56:35 +0800
committerale <ale@FreeBSD.org>2006-06-13 00:56:35 +0800
commitfe51e198db2f3f64c4dce839671671f23fc03072 (patch)
tree7272be4dd8ca8139eec1d8beba8144b03396af65 /security/openssh-portable
parentfdf66c883fe4c82b95a0d96ee953ef08cf442c0c (diff)
downloadfreebsd-ports-gnome-fe51e198db2f3f64c4dce839671671f23fc03072.tar.gz
freebsd-ports-gnome-fe51e198db2f3f64c4dce839671671f23fc03072.tar.zst
freebsd-ports-gnome-fe51e198db2f3f64c4dce839671671f23fc03072.zip
Add support for smart cards.
Approved by: maintainer
Diffstat (limited to 'security/openssh-portable')
-rw-r--r--security/openssh-portable/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index 00c1e6b7c8f5..bc13ce810fe0 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -60,6 +60,7 @@ OPTIONS= PAM "Enable pam(3) support" on \
SUID_SSH "Enable suid SSH (Recommended off)" off \
GSSAPI "Enable GSSAPI support" off \
OPENSSH_CHROOT "Enable CHROOT support" off \
+ OPENSC "Enable OpenSC smartcard support" off \
HPN "Enable HPN-11 SSH/SCP patch" off \
HPN_NONECIPHER "Enable HPN-11 with None Cipher patch" off \
OVERWRITE_BASE "OpenSSH overwrite base" off
@@ -122,6 +123,11 @@ CONFIGURE_ARGS+= --with-ssl-dir=${OPENSSLBASE}
CFLAGS+= -DCHROOT
.endif
+.if defined(WITH_OPENSC)
+LIB_DEPENDS+= opensc.2:${PORTSDIR}/security/opensc
+CONFIGURE_ARGS+= --with-opensc=${LOCALBASE}
+.endif
+
.if defined(WITH_HPN)
.if defined(WITH_HPN_NONECIPHER)
IGNORE= please, select only one HPN patch. Rerun 'make config'