aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssh/Makefile
diff options
context:
space:
mode:
authorgreen <green@FreeBSD.org>1999-11-11 22:33:23 +0800
committergreen <green@FreeBSD.org>1999-11-11 22:33:23 +0800
commit62ec514eda0d5a49023c6b5473a700c950201923 (patch)
treea175e9267c78e5f0bc976fd0f78f0ed70d4dd6ff /security/openssh/Makefile
parent3e923c9ccf833233f7e8b8f516ba5226d954a061 (diff)
downloadfreebsd-ports-gnome-62ec514eda0d5a49023c6b5473a700c950201923.tar.gz
freebsd-ports-gnome-62ec514eda0d5a49023c6b5473a700c950201923.tar.zst
freebsd-ports-gnome-62ec514eda0d5a49023c6b5473a700c950201923.zip
Quite a bit of change to OpenSSH made:
Add "/usr/local/bin" to _PATH_STDPATH (makes scp work inbound, for instance.) Fetch OpenSSH from OpenBSD's src tree. This uses a script and ftp(1). Add strlcpy.c to ssh/lib, so this port should build on 3.X now. Make TCP_WRAPPERS conditional on /usr/include/tcpd.h like the PR, so it should build on older RELEASEs without TCP Wrappers. The PR is still open because I am taking more from it. PR: ports/14653
Diffstat (limited to 'security/openssh/Makefile')
-rw-r--r--security/openssh/Makefile17
1 files changed, 16 insertions, 1 deletions
diff --git a/security/openssh/Makefile b/security/openssh/Makefile
index 1b6179bc83b3..b108926f43df 100644
--- a/security/openssh/Makefile
+++ b/security/openssh/Makefile
@@ -8,12 +8,14 @@
DISTNAME= OpenSSH-1.2
CATEGORIES= security
-MASTER_SITES= http://www.FreeBSD.org/~green/
+MASTER_SITES= # see ${SCRIPTDIR}/fetchit
MAINTAINER= green@FreeBSD.org
LIB_DEPENDS= crypto.1:${PORTSDIR}/security/openssl
+RESTRICTED= "Links with cryptographic code."
+
# Here, MANDIR is concetenated to DESTDIR which all forms the man install dir...
MAKE_ENV= DESTDIR=${PREFIX} MANDIR=/man/man
.if defined(USA_RESIDENT) && ${USA_RESIDENT} == YES
@@ -21,8 +23,21 @@ MAKE_ENV+= CRYPTOLIBS="-L${PREFIX}/lib -lcrypto -lRSAglue -lrsaref"
.else
MAKE_ENV+= CRYPTOLIBS="-L${PREFIX}/lib -lcrypto"
.endif
+.if !exists(/usr/include/tcpd.h)
+MAKE_ENV+= TCP_WRAPPERS=NO
+.endif
+NO_CHECKSUM= YES
WRKSRC= ${WRKDIR}/ssh
+do-fetch:
+.if !exists(${WRKDIR}/.fetch_done)
+ @${SETENV} WRKDIR=${WRKDIR} ${SCRIPTDIR}/fetchit)
+.endif
+ @${TOUCH} ${WRKDIR}/.fetch_done
+
+do-extract:
+ @${CP} ${FILESDIR}/strlcpy.c ${WRKSRC}/lib/
+
pre-install:
@cd ${WRKSRC} && ${MAKE} DESTDIR=${PREFIX} distribution