aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssh
diff options
context:
space:
mode:
authorgreen <green@FreeBSD.org>2000-07-31 03:14:17 +0800
committergreen <green@FreeBSD.org>2000-07-31 03:14:17 +0800
commit2d4c81d09d9df4473bd3a0adf425f99ab31f717c (patch)
treef16bca131689f6a716ecdf4e63c4ecd2c6634440 /security/openssh
parentb6063f67a9ac530ff4a1fbfdb759a11bd360589f (diff)
downloadfreebsd-ports-gnome-2d4c81d09d9df4473bd3a0adf425f99ab31f717c.tar.gz
freebsd-ports-gnome-2d4c81d09d9df4473bd3a0adf425f99ab31f717c.tar.zst
freebsd-ports-gnome-2d4c81d09d9df4473bd3a0adf425f99ab31f717c.zip
Fix Kerberos 4 support.
Mostly submitted by: Mark A Gebert <geeb@thugsrus.org>
Diffstat (limited to 'security/openssh')
-rw-r--r--security/openssh/files/patch-ag14
-rw-r--r--security/openssh/files/patch-am16
2 files changed, 24 insertions, 6 deletions
diff --git a/security/openssh/files/patch-ag b/security/openssh/files/patch-ag
index 12c47019780c..d9170272757b 100644
--- a/security/openssh/files/patch-ag
+++ b/security/openssh/files/patch-ag
@@ -1,5 +1,5 @@
---- ssh/Makefile.orig Thu Apr 27 06:31:58 2000
-+++ ssh/Makefile Fri May 12 07:23:01 2000
+--- ssh/Makefile.orig Wed Apr 26 17:31:58 2000
++++ ssh/Makefile Sun Jul 30 15:09:14 2000
@@ -2,16 +2,10 @@
PROG= ssh
@@ -20,14 +20,20 @@
LINKS= ${BINDIR}/ssh ${BINDIR}/slogin
MLINKS= ssh.1 slogin.1
-@@ -19,6 +13,7 @@
+@@ -19,10 +13,11 @@
sshconnect.c sshconnect1.c sshconnect2.c
.include <bsd.own.mk> # for AFS
+.include "../Makefile.inc"
.if (${KERBEROS} == "yes")
- CFLAGS+= -DKRB4 -I${DESTDIR}/usr/include/kerberosIV
+-CFLAGS+= -DKRB4 -I${DESTDIR}/usr/include/kerberosIV
+-LDADD+= -lkrb
++CFLAGS+= -DKRB4 -I/usr/include/kerberosIV
++LDADD+= -lkrb -lcom_err
+ DPADD+= ${LIBKRB}
+ .if (${AFS} == "yes")
+ CFLAGS+= -DAFS
@@ -32,6 +27,7 @@
.endif # KERBEROS
diff --git a/security/openssh/files/patch-am b/security/openssh/files/patch-am
index 95eeb35accb6..fee853eadee2 100644
--- a/security/openssh/files/patch-am
+++ b/security/openssh/files/patch-am
@@ -1,5 +1,5 @@
---- sshd/Makefile.orig Thu Apr 27 06:31:57 2000
-+++ sshd/Makefile Fri May 12 07:10:41 2000
+--- sshd/Makefile.orig Wed Apr 26 17:31:57 2000
++++ sshd/Makefile Sun Jul 30 15:09:25 2000
@@ -3,14 +3,15 @@
PROG= sshd
BINOWN= root
@@ -18,6 +18,18 @@
.if (${KERBEROS} == "yes")
.if (${AFS} == "yes")
+@@ -18,9 +19,9 @@
+ LDADD+= -lkafs
+ DPADD+= ${LIBKRBAFS}
+ .endif # AFS
+-CFLAGS+= -DKRB4 -I${DESTDIR}/usr/include/kerberosIV
++CFLAGS+= -DKRB4 -I/usr/include/kerberosIV
+ SRCS+= auth-krb4.c
+-LDADD+= -lkrb
++LDADD+= -lkrb -lcom_err
+ DPADD+= ${LIBKRB}
+ .endif # KERBEROS
+
@@ -30,7 +31,7 @@
.include <bsd.prog.mk>
n class='insertions'>+57 * Update to 0.7perky2003-09-282-2/+2 * Update to 0.6perky2003-09-252-3/+2 * Add a workaround to avoid a fatal confliction with qt32.perky2003-09-192-0/+21 * Remove ko-qt31. We are happy with mainstream qt 3.2.1 now.perky2003-09-195-75/+0 * Point to the QT 3.2 Makefile instead of the 3.1 Makefile. This directorymarcus2003-09-191-1/+1 * Upgrade to Qt 3.2.1 / KDE 3.1.4. See x11/kde3/Makefile rev 1.64 for details.will2003-09-182-2/+0 * Add missing \erwin2003-09-091-1/+1 * Fix distfiles/www locations and one maintainer.cjh2003-09-099-18/+10 * Fix distfiles location.cjh2003-09-097-8/+7 * Fix non-i386 builds proposed by the submitter.cjh2003-09-091-2/+2 * * Support CFLAGStaoka2003-09-021-0/+1 * Update to 0.6.4perky2003-09-012-2/+2 * Update to 0.4perky2003-08-283-31/+24 * Bump the PORTREVISION for the ports directly affected by the gettext upgrade.marcus2003-08-271-1/+1 * Chase the libintl.so shared lib version.marcus2003-08-251-1/+1 * Add two knobs that changes default keyboard layout:perky2003-08-251-0/+5 * Update to 0.6.3perky2003-08-232-2/+2 * Update to 0.6.2perky2003-08-213-23/+19 * Add a missing dependency on py-cjkcodecsperky2003-08-201-1/+2 * Add port for GDick 0.6.1, a English<->Korean Dictionary for GTK2/GNOME2perky2003-08-206-0/+69