aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssh
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2001-06-11 04:01:52 +0800
committerdinoex <dinoex@FreeBSD.org>2001-06-11 04:01:52 +0800
commitf703b24680f2db093b51594e0b729e1dcf5f4720 (patch)
tree3a1e35b49580a790d5bc8d92e6c4e020bd905295 /security/openssh
parentfd5d7a613aaf591b693890d2301cef9d749f4b87 (diff)
downloadfreebsd-ports-gnome-f703b24680f2db093b51594e0b729e1dcf5f4720.tar.gz
freebsd-ports-gnome-f703b24680f2db093b51594e0b729e1dcf5f4720.tar.zst
freebsd-ports-gnome-f703b24680f2db093b51594e0b729e1dcf5f4720.zip
- Fix FreeBSD specific patch, exit now if change of password fails.
Forwarded by dwcjr Submitted by: Udo.Schweigert@cert.siemens.de
Diffstat (limited to 'security/openssh')
-rw-r--r--security/openssh/Makefile2
-rw-r--r--security/openssh/files/patch-au8
2 files changed, 6 insertions, 4 deletions
diff --git a/security/openssh/Makefile b/security/openssh/Makefile
index ca19bd0e51ee..bf73e9438cd0 100644
--- a/security/openssh/Makefile
+++ b/security/openssh/Makefile
@@ -7,7 +7,7 @@
PORTNAME= OpenSSH
PORTVERSION= 2.9
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/ \
ftp://ftp.usa.openbsd.org/pub/OpenBSD/OpenSSH/ \
diff --git a/security/openssh/files/patch-au b/security/openssh/files/patch-au
index 9a63dcabe805..23d255a0f62a 100644
--- a/security/openssh/files/patch-au
+++ b/security/openssh/files/patch-au
@@ -1,5 +1,5 @@
--- session.c.orig Tue Apr 17 21:34:25 2001
-+++ session.c Sat May 26 15:45:15 2001
++++ session.c Sun Jun 10 19:42:13 2001
@@ -58,6 +58,12 @@
#include "canohost.h"
#include "session.h"
@@ -84,7 +84,7 @@
close(i);
/* Change current directory to the user\'s home directory. */
-@@ -1051,6 +1091,26 @@
+@@ -1051,6 +1091,28 @@
* in this order).
*/
if (!options.use_login) {
@@ -103,8 +103,10 @@
+ syslog(LOG_INFO,
+ "%s Password expired - forcing change",
+ pw->pw_name);
-+ if (system("/usr/bin/passwd") != 0)
++ if (system("/usr/bin/passwd") != 0) {
+ perror("/usr/bin/passwd");
++ exit(1);
++ }
+ }
+ }
+#endif /* __FreeBSD__ */