aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssl/Makefile
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2010-04-07 03:16:05 +0800
committerdinoex <dinoex@FreeBSD.org>2010-04-07 03:16:05 +0800
commit27050827f9dad58699d6664a4b681ad26c95289f (patch)
treec5dcb9505c421a94449ae248341e511646fae770 /security/openssl/Makefile
parentfc4d0b5fc2d3f509d4163fc685cf996b87d940d6 (diff)
downloadfreebsd-ports-gnome-27050827f9dad58699d6664a4b681ad26c95289f.tar.gz
freebsd-ports-gnome-27050827f9dad58699d6664a4b681ad26c95289f.tar.zst
freebsd-ports-gnome-27050827f9dad58699d6664a4b681ad26c95289f.zip
- add option WITHOUT_ASM
Diffstat (limited to 'security/openssl/Makefile')
-rw-r--r--security/openssl/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index a25a5596f141..088801b4f59d 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -28,6 +28,7 @@ BUILD_DEPENDS= makedepend:${PORTSDIR}/devel/makedepend
OPTIONS= I386 "Use optimized assembler for 80386" off \
SSE2 "Use runtime SSE2 detection" on \
+ ASM "Build with optimized Assembler" on \
ZLIB "Build with zlib compression" on \
MD2 "Build with MD2 hash (obsolete)" off \
RC5 "Build with RC5 chipher (patented)" off \
@@ -1054,6 +1055,12 @@ EXTRACONFIGURE+= 386
EXTRACONFIGURE+= no-sse2
.endif
+.if !defined(WITHOUT_ASM)
+EXTRACONFIGURE+= enable-asm
+.else
+EXTRACONFIGURE+= no-asm
+.endif
+
.if defined(NOSHARED)
PLIST_SUB+= SHARED="@comment "
.else