aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssl/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2007-01-30 18:25:34 +0800
committerpav <pav@FreeBSD.org>2007-01-30 18:25:34 +0800
commit68e4663f01d748743e0029f83931c02fba58eb4e (patch)
treed24dbe32e4bdb87d0f3ba1c46717e6e34576e724 /security/openssl/Makefile
parentc6c1440c2b66077bedba90612a4827a8051ec9c1 (diff)
downloadfreebsd-ports-gnome-68e4663f01d748743e0029f83931c02fba58eb4e.tar.gz
freebsd-ports-gnome-68e4663f01d748743e0029f83931c02fba58eb4e.tar.zst
freebsd-ports-gnome-68e4663f01d748743e0029f83931c02fba58eb4e.zip
- Remove support for a.out format and PORTOBJFORMAT variable from individual
ports With hat: portmgr
Diffstat (limited to 'security/openssl/Makefile')
-rw-r--r--security/openssl/Makefile7
1 files changed, 1 insertions, 6 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 6e988b708710..6f31810316d9 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -60,6 +60,7 @@ PLIST_SUB+= OPENSSL_STABLE="@comment "
CONFLICTS?= openssl-beta-0.* openssl-stable-0.*
.endif
+MAKE_ARGS+= WHOLE_ARCHIVE_FLAG=--whole-archive
MAKE_ENV+= MANPREFIX=${MANPREFIX}
NOPRECIOUSMAKEVARS= Too many _MLINKS for fetch
NOPRECIOUSSOFTMAKEVARS= Too many _MLINKS for fetch
@@ -882,12 +883,6 @@ MLINKS+= \
.include <bsd.port.pre.mk>
-.if ${PORTOBJFORMAT} == "aout"
-MAKE_ARGS+= WHOLE_ARCHIVE_FLAG=-Bforcearchive
-.else
-MAKE_ARGS+= WHOLE_ARCHIVE_FLAG=--whole-archive
-.endif
-
OPENSSL_BASE_SONAME!= readlink ${DESTDIR}/usr/lib/libcrypto.so || true
OPENSSL_SHLIBVER_BASE= ${OPENSSL_BASE_SONAME:E}
OPENSSL_BASE_SOPATH= ${OPENSSL_BASE_SONAME:H}