aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssl/Makefile
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2006-08-31 12:52:57 +0800
committerdinoex <dinoex@FreeBSD.org>2006-08-31 12:52:57 +0800
commitb065f9ec36ea0e0ccc57a5927741b294b28ed2b2 (patch)
tree8de501c098edab33a0a97a2520e54034a613139b /security/openssl/Makefile
parent3cd5279ad8a5c6b6c3136f952f9fbcaee7c2c723 (diff)
downloadfreebsd-ports-gnome-b065f9ec36ea0e0ccc57a5927741b294b28ed2b2.tar.gz
freebsd-ports-gnome-b065f9ec36ea0e0ccc57a5927741b294b28ed2b2.tar.zst
freebsd-ports-gnome-b065f9ec36ea0e0ccc57a5927741b294b28ed2b2.zip
- fix warning when no openssl is in the base
PR: 102639 Submitted by: Artis Caune
Diffstat (limited to 'security/openssl/Makefile')
-rw-r--r--security/openssl/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index b4152b7f062b..0b7bdf2e606c 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -888,7 +888,7 @@ MAKE_ARGS+= WHOLE_ARCHIVE_FLAG=-Bforcearchive
MAKE_ARGS+= WHOLE_ARCHIVE_FLAG=--whole-archive
.endif
-OPENSSL_BASE_SONAME!= readlink ${DESTDIR}/usr/lib/libcrypto.so
+OPENSSL_BASE_SONAME!= readlink ${DESTDIR}/usr/lib/libcrypto.so || true
OPENSSL_SHLIBVER_BASE= ${OPENSSL_BASE_SONAME:E}
OPENSSL_BASE_SOPATH= ${OPENSSL_BASE_SONAME:H}