aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssl/Makefile
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2009-05-21 03:22:47 +0800
committerdinoex <dinoex@FreeBSD.org>2009-05-21 03:22:47 +0800
commitd3b98ee57b31bcb51d4010c1f3fd57441a18e903 (patch)
tree3d7cab450e95b1f0ea6a19b20d1efa9f489e2703 /security/openssl/Makefile
parent14a9f6a8529869560bd035b665a00a72181900a6 (diff)
downloadfreebsd-ports-gnome-d3b98ee57b31bcb51d4010c1f3fd57441a18e903.tar.gz
freebsd-ports-gnome-d3b98ee57b31bcb51d4010c1f3fd57441a18e903.tar.zst
freebsd-ports-gnome-d3b98ee57b31bcb51d4010c1f3fd57441a18e903.zip
- add more DTLS bugfixes
- use options framework - new option WITH_FIPS add fips code - new option WITH_SCTP add SCTP support to openssl
Diffstat (limited to 'security/openssl/Makefile')
-rw-r--r--security/openssl/Makefile41
1 files changed, 35 insertions, 6 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 222d957a8bb2..e86cab424bb0 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -7,13 +7,15 @@
PORTNAME= openssl
PORTVERSION= 0.9.8k
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security devel
MASTER_SITES= http://www.openssl.org/%SUBDIR%/ \
ftp://ftp.openssl.org/%SUBDIR%/ \
ftp://ftp.sunet.se/pub/security/tools/net/openssl/%SUBDIR%/ \
ftp://ftp.cert.dfn.de/pub/tools/net/openssl/%SUBDIR%/
MASTER_SITE_SUBDIR= source
+PATCH_SITES= http://sctp.fh-muenster.de/dtls/
+PATCHFILES= dtls-bugs.patch
DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= dinoex@FreeBSD.org
@@ -25,6 +27,11 @@ BUILD_DEPENDS= makedepend:${PORTSDIR}/devel/makedepend
.error You have `USE_OPENSSL' variable defined either in environment or in make(1) arguments. Please undefine and try again.
.endif
+OPTIONS= I386 "Use optimzed assembler for 80386" off \
+ SSE2 "Use runtime SSE2 detection" on \
+ ZLIB "Build with zlib compression" on \
+ SCTP "Build with SCTP support" off \
+
EXTRACONFIGURE+= enable-camellia
MAKE_ARGS+= WHOLE_ARCHIVE_FLAG=--whole-archive
@@ -849,11 +856,13 @@ OPENSSL_SHLIBVER_BASE= ${OPENSSL_BASE_SONAME:E}
OPENSSL_BASE_SOPATH= ${OPENSSL_BASE_SONAME:H}
OPENSSL_SHLIBVER?= 5
+.if !defined(WITHOUT_SSE2)
# disable runtime SSE2 detection
-.if defined(WITHOUT_OPENSSL_SSE2)
EXTRACONFIGURE+= no-sse2
.endif
+.if !defined(WITH_FIPS)
EXTRACONFIGURE+= no-fips
+.endif
.if defined(NOSHARED)
PLIST_SUB+= SHARED="@comment "
.else
@@ -864,10 +873,20 @@ PLIST_SUB+= SHLIBVER=${OPENSSL_SHLIBVER}
USE_LDCONFIG= yes
.endif
-.if defined(WITH_OPENSSL_COMPRESSION)
+.if !defined(WITHOUT_ZLIB)
EXTRACONFIGURE+= zlib
.endif
+.if defined(WITH_SCTP)
+.if ${OSVERSION} >= 700000
+PATCHFILES+= tls-extractor.patch \
+ abbreviated-renegotiation.patch \
+ dtls-sctp.patch
+# freebsd-compatibility.patch
+CFLAGS+= -DSCTP
+.endif
+.endif
+
.if ${OPENSSL_SHLIBVER_BASE} > ${OPENSSL_SHLIBVER}
pre-everything::
@${ECHO_CMD} "#"
@@ -881,21 +900,30 @@ pre-everything::
OPENSSLDIR= ${PREFIX}/openssl
MANPREFIX= ${PREFIX}
-.if defined(BATCH) || defined(OPENSSL_WITH_386)
+.if defined(WITH_I386)
.if ${ARCH} == "i386"
EXTRACONFIGURE+= 386
.endif
.endif
do-configure:
+.if !defined(WITH_FIPS)
${RM} -rf ${WRKSRC}/fips
${RM} -f ${WRKSRC}/include/openssl/fips.h
${RM} -f ${WRKSRC}/include/openssl/fips_rand.h
+.endif
cd ${WRKSRC} \
&& ${SETENV} CC="${CC}" FREEBSDCC="${CC}" CFLAGS="${CFLAGS}" PERL="${PERL}" \
- PTHREAD_CFLAGS=${PTHREAD_CFLAGS} PTHREAD_LIBS=${PTHREAD_LIBS} \
+ PTHREAD_CFLAGS=${PTHREAD_CFLAGS} PTHREAD_LIBS=${PTHREAD_LIBS} \
./config --prefix=${PREFIX} --openssldir=${OPENSSLDIR} \
- -L${PREFIX}/lib ${EXTRACONFIGURE}
+ -L${PREFIX}/lib ${EXTRACONFIGURE}
+.if defined(WITH_FIPS)
+ @${REINPLACE_CMD} \
+ -e 's|^MANDIR=.*$$|MANDIR=$$(MANPREFIX)/man|' \
+ -e 's|lib/pkgconfig|libdata/pkgconfig|g' \
+ -e 's|LIBVERSION=[^ ]* |LIBVERSION=$(OPENSSL_SHLIBVER) |' \
+ ${WRKSRC}/Makefile
+.else
@${REINPLACE_CMD} \
-e 's|^MANDIR=.*$$|MANDIR=$$(MANPREFIX)/man|' \
-e 's|lib/pkgconfig|libdata/pkgconfig|g' \
@@ -920,6 +948,7 @@ do-configure:
-e 's|$$(FIPS_RNGVS)$$(EXE_EXT)||' \
-e 's|$$(FIPS_TEST_SUITE)$$(EXE_EXT)||' \
${WRKSRC}/test/Makefile
+.endif
@(cd ${BUILD_WRKSRC}/${i} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} depend)
post-install: