aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssl/Makefile
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2002-09-15 21:01:05 +0800
committerdinoex <dinoex@FreeBSD.org>2002-09-15 21:01:05 +0800
commitf75abf2d9044054e94717b2185beea07f6a38f20 (patch)
treebf13a616147ff73cc41831f297473537f9f6d4a3 /security/openssl/Makefile
parent171c5d661929a70618db83dcb0bb9735a444e8b6 (diff)
downloadfreebsd-ports-gnome-f75abf2d9044054e94717b2185beea07f6a38f20.tar.gz
freebsd-ports-gnome-f75abf2d9044054e94717b2185beea07f6a38f20.tar.zst
freebsd-ports-gnome-f75abf2d9044054e94717b2185beea07f6a38f20.zip
fix path for option OPENSSL_OVERWRITE_BASE
PR: 42665 Submitted by: roman@bellavista.cz
Diffstat (limited to 'security/openssl/Makefile')
-rw-r--r--security/openssl/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 315b1ba4feeb..17ab730776cb 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -42,6 +42,9 @@ INSTALLS_SHLIB= yes
PKGNAMESUFFIX= -overwrite-base
PREFIX= /usr
SHLIBVER= 2
+OPENSSLDIR= /etc/ssl
+.else
+OPENSSLDIR= ${PREFIX}/openssl
.endif
MANPREFIX= ${PREFIX}/openssl
@@ -128,7 +131,7 @@ EXTRACONFIGURE= 386
do-configure:
@cd ${WRKSRC} \
&& ${SETENV} CC="${CC}" CFLAGS="${CFLAGS}" PERL="${PERL}" \
- ./config --prefix=${PREFIX} --openssldir=${PREFIX}/openssl \
+ ./config --prefix=${PREFIX} --openssldir=${OPENSSLDIR} \
-L${PREFIX}/lib ${EXTRACONFIGURE}
post-install: