aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssl/Makefile
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2008-03-29 19:27:32 +0800
committerdinoex <dinoex@FreeBSD.org>2008-03-29 19:27:32 +0800
commitf7d39da611a7bfee44e7a8309077f50e8313ec65 (patch)
tree94f40a49285576247a78796b88f775ff2c808080 /security/openssl/Makefile
parent8e6d4c9f87b83a2b01bf6ba63bd97d8d4928d30c (diff)
downloadfreebsd-ports-gnome-f7d39da611a7bfee44e7a8309077f50e8313ec65.tar.gz
freebsd-ports-gnome-f7d39da611a7bfee44e7a8309077f50e8313ec65.tar.zst
freebsd-ports-gnome-f7d39da611a7bfee44e7a8309077f50e8313ec65.zip
- remove WITH_OPENSSL_SNAPSHOT
Diffstat (limited to 'security/openssl/Makefile')
-rw-r--r--security/openssl/Makefile20
1 files changed, 3 insertions, 17 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 69342a373baa..08f05d952f58 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -6,10 +6,6 @@
#
PORTNAME= openssl
-.if defined(WITH_OPENSSL_SNAPSHOT)
-PORTVERSION= 0.9.8
-PORTREVISION!= date -v-1d +%Y%m%d
-.else
.if !defined(WITH_OPENSSL_BETA) && ( defined(WITH_OPENSSL_097) || defined(WITH_OPENSSL_STABLE) )
PORTVERSION= 0.9.7m
PORTREVISION?= 0
@@ -17,15 +13,14 @@ PORTREVISION?= 0
PORTVERSION= 0.9.8g
PORTREVISION?= 0
.endif
-.endif
CATEGORIES= security devel
MASTER_SITES= http://www.openssl.org/%SUBDIR%/ \
ftp://ftp.openssl.org/%SUBDIR%/ \
ftp://ftp.sunet.se/pub/security/tools/net/openssl/%SUBDIR%/ \
ftp://ftp.cert.dfn.de/pub/tools/net/openssl/%SUBDIR%/
-MASTER_SITE_SUBDIR= ${MASTER_SITE_SUBDIR2}
+MASTER_SITE_SUBDIR= source
PKGNAMESUFFIX?= ${BETA_SUFFIX}${BASE_SUFFIX}${PKGNAMESUFFIX2}
-DISTNAME= ${DISTNAME2}
+DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= SSL and crypto library
@@ -34,16 +29,7 @@ COMMENT= SSL and crypto library
.error You have `USE_OPENSSL' variable defined either in environment or in make(1) arguments. Please undefine and try again.
.endif
-.if defined(WITH_OPENSSL_SNAPSHOT)
-MASTER_SITE_SUBDIR2= snapshot
-DISTNAME2= ${PORTNAME}-${PORTVERSION}-stable-SNAP-${PORTREVISION}
-NO_CHECKSUM= yes
-.else
-MASTER_SITE_SUBDIR2= source
-DISTNAME2= ${PORTNAME}-${PORTVERSION}
-.endif
-
-.if defined(WITH_OPENSSL_BETA) || defined(WITH_OPENSSL_SNAPSHOT)
+.if defined(WITH_OPENSSL_BETA)
BETA_SUFFIX= -beta
CONFLICTS?= openssl-0.* openssl-stable-0.*
NO_LATEST_LINK= yes