aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssl/Makefile
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2002-10-26 04:41:47 +0800
committerdinoex <dinoex@FreeBSD.org>2002-10-26 04:41:47 +0800
commitfe53f9d2212184099aea0ff30dc7a1188344847d (patch)
tree7a0a0649b589b0708d88de31634475ba2ed65a3c /security/openssl/Makefile
parentcd47823382463ee407168dc4e8128f3e0534b513 (diff)
downloadfreebsd-ports-gnome-fe53f9d2212184099aea0ff30dc7a1188344847d.tar.gz
freebsd-ports-gnome-fe53f9d2212184099aea0ff30dc7a1188344847d.tar.zst
freebsd-ports-gnome-fe53f9d2212184099aea0ff30dc7a1188344847d.zip
- add rnd_keys.c for compatibilty with base. (patch by: jtraub@isilon.com)
- OPENSSL_OVERWRITE_BASE: fix package building - Fix install of manpages for 3.x
Diffstat (limited to 'security/openssl/Makefile')
-rw-r--r--security/openssl/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 2738786de6c7..21e465f60bff 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openssl
PORTVERSION= 0.9.6g
+PORTREVISION= 1
CATEGORIES= security devel
MASTER_SITES= http://www.openssl.org/source/ \
ftp://ftp.openssl.org/source/ \
@@ -46,13 +47,14 @@ SHLIBVER= 2
OPENSSLDIR= /etc/ssl
MANPREFIX= ${PREFIX}/openssl
PLIST_SUB+= MANDIR=""
+PLIST_SUB+= NOBASE="@comment "
.else
OPENSSLDIR= ${PREFIX}/openssl
MANPREFIX= ${PREFIX}
PLIST_SUB+= MANDIR="@comment "
+PLIST_SUB+= NOBASE=""
.endif
-MANPREFIX= ${PREFIX}
MAKE_ENV+= MANPREFIX=${MANPREFIX}
MAN1= CA.pl.1 asn1parse.1 ca.1 ciphers.1 crl.1 crl2pkcs7.1 dgst.1 \
@@ -135,6 +137,13 @@ EXTRACONFIGURE= 386
.endif
do-configure:
+.if exists(/usr/src/crypto/openssl/crypto/des/rnd_keys.c)
+ ${CP} /usr/src/crypto/openssl/crypto/des/rnd_keys.c \
+ ${WRKSRC}/crypto/des/rnd_keys.c
+.else
+ ${CP} ${FILESDIR}/rnd_keys.c \
+ ${WRKSRC}/crypto/des/rnd_keys.c
+.endif
@cd ${WRKSRC} \
&& ${SETENV} CC="${CC}" CFLAGS="${CFLAGS}" PERL="${PERL}" \
./config --prefix=${PREFIX} --openssldir=${OPENSSLDIR} \