aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssl/Makefile
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2006-05-25 23:17:34 +0800
committerdinoex <dinoex@FreeBSD.org>2006-05-25 23:17:34 +0800
commitce69ab9a0c1b0afb28b48b21d8a220369045e93d (patch)
treed8b0aa25aae1b9efaaa3bd2efc1634e80414c1ee /security/openssl/Makefile
parentf8fbe8683ca2bfe25bd4f9902c996daffb546aae (diff)
downloadfreebsd-ports-gnome-ce69ab9a0c1b0afb28b48b21d8a220369045e93d.tar.gz
freebsd-ports-gnome-ce69ab9a0c1b0afb28b48b21d8a220369045e93d.tar.zst
freebsd-ports-gnome-ce69ab9a0c1b0afb28b48b21d8a220369045e93d.zip
- bump shared lib versions for FreeBSD > 6.0
libssl.o in the base was bumped, but still uses old ABI KDE crashes, as it does not honor LDFLAGS / -rpath= - solving regression for OpenOffice users Reported by: Michel Talon
Diffstat (limited to 'security/openssl/Makefile')
-rw-r--r--security/openssl/Makefile26
1 files changed, 15 insertions, 11 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 652e98da6823..23008e30ae4c 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -6,14 +6,6 @@
#
PORTNAME= openssl
-.if !defined(WITHOUT_OPENSSL_097) && !defined(WITH_OPENSSL_BETA)
-.if !defined(OSVERSION6)
-OSVERSION6!= make OSVERSION6=0 -V OSVERSION
-.endif
-.if ( ${OSVERSION6} >= 600000 ) && ( ${OSVERSION6} < 600100 )
-WITH_OPENSSL_097= yes
-.endif
-.endif
.if defined(WITH_OPENSSL_SNAPSHOT)
PORTVERSION= 0.9.8
PORTREVISION!= date -v-1d +%Y%m%d
@@ -23,7 +15,7 @@ PORTVERSION= 0.9.7j
PORTREVISION?= 0
.else
PORTVERSION= 0.9.8b
-PORTREVISION?= 0
+PORTREVISION?= 1
.endif
.endif
CATEGORIES= security devel
@@ -60,13 +52,11 @@ NO_LATEST_LINK= yes
BETA_SUFFIX= -stable
PLIST_SUB+= OPENSSL_BETA="@comment "
PLIST_SUB+= OPENSSL_STABLE=""
-OPENSSL_SHLIBVER?= 3
CONFLICTS?= openssl-0.* openssl-beta-0.*
.else
PATCHDIR= ${MASTERDIR}/files-beta
PLIST_SUB+= OPENSSL_BETA=""
PLIST_SUB+= OPENSSL_STABLE="@comment "
-OPENSSL_SHLIBVER?= 4
CONFLICTS?= openssl-beta-0.* openssl-stable-0.*
.endif
@@ -898,6 +888,20 @@ MAKE_ARGS+= WHOLE_ARCHIVE_FLAG=-Bforcearchive
MAKE_ARGS+= WHOLE_ARCHIVE_FLAG=--whole-archive
.endif
+.if defined(WITH_OPENSSL_097) || defined(WITH_OPENSSL_STABLE)
+.if ( ${OSVERSION} >= 600100 )
+OPENSSL_SHLIBVER?= 4
+.else
+OPENSSL_SHLIBVER?= 3
+.endif
+.else
+.if ( ${OSVERSION} >= 600100 )
+OPENSSL_SHLIBVER?= 5
+.else
+OPENSSL_SHLIBVER?= 4
+.endif
+.endif
+
# disable runtime SSE2 detection
.if defined(WITHOUT_OPENSSL_SSE2)
EXTRACONFIGURE+= no-sse2