aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssl
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2004-03-27 03:57:26 +0800
committerdinoex <dinoex@FreeBSD.org>2004-03-27 03:57:26 +0800
commit2ee2dfb818d6aa69356b87e4b4bd882b6b625f68 (patch)
tree1757305710bd63c5961fc72e0272b8240589185c /security/openssl
parent2bba6960760ff14f65edd3da49f1b3dc72d0747e (diff)
downloadfreebsd-ports-gnome-2ee2dfb818d6aa69356b87e4b4bd882b6b625f68.tar.gz
freebsd-ports-gnome-2ee2dfb818d6aa69356b87e4b4bd882b6b625f68.tar.zst
freebsd-ports-gnome-2ee2dfb818d6aa69356b87e4b4bd882b6b625f68.zip
- make PKGNAMESUFFIX more flexible
- merge lines from openssl-beta
Diffstat (limited to 'security/openssl')
-rw-r--r--security/openssl/Makefile35
1 files changed, 29 insertions, 6 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 5c678ecf9122..1ed2325517fe 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -6,12 +6,19 @@
#
PORTNAME= openssl
+.if defined(OPENSSL_SNAPSHOT)
+PORTREVISION!= date -v-1d +%Y%m%d
+.else
PORTVERSION= 0.9.7d
+.endif
CATEGORIES= security devel
-MASTER_SITES= http://www.openssl.org/source/ \
- ftp://ftp.openssl.org/source/ \
- ftp://ftp.sunet.se/pub/security/tools/net/openssl/source/ \
- ftp://ftp.cert.dfn.de/pub/tools/net/openssl/source/
+MASTER_SITES= http://www.openssl.org/%SUBDIR%/ \
+ ftp://ftp.openssl.org/%SUBDIR%/ \
+ ftp://ftp.sunet.se/pub/security/tools/net/openssl/%SUBDIR%/ \
+ ftp://ftp.cert.dfn.de/pub/tools/net/openssl/%SUBDIR%/
+MASTER_SITE_SUBDIR= ${MASTER_SITE_SUBDIR2}
+PKGNAMESUFFIX?= ${BETA_SUFFIX}${BASE_SUFFIX}${PKGNAMESUFFIX2}
+DISTNAME= ${DISTNAME2}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= SSL and crypto library
@@ -20,11 +27,27 @@ COMMENT= SSL and crypto library
.error You have `USE_OPENSSL' variable defined either in environment or in make(1) arguments. Please undefine and try again.
.endif
+.if defined(OPENSSL_SNAPSHOT)
+MASTER_SITE_SUBDIR2= snapshot
+DISTNAME2= ${PORTNAME}-${PORTVERSION}-stable-SNAP-${PORTREVISION}
+.else
+MASTER_SITE_SUBDIR2= source
+DISTNAME2= ${PORTNAME}-${PORTVERSION}
+.endif
+
+.if defined(WITH_OPENSSL_BETA)
+BETA_SUFFIX= -beta
+CONFLICTS?= openssl-0.*
+OPENSSL_SHLIBVER?= 4
+NO_LATEST_LINK= yes
+.else
CONFLICTS?= openssl-beta-0.*
+OPENSSL_SHLIBVER?= 3
+.endif
+
MAKE_ENV+= MANPREFIX=${MANPREFIX}
NOPRECIOUSMAKEVARS= Too many _MLINKS for fetch
USE_PERL5_BUILD= yes
-OPENSSL_SHLIBVER?= 3
CFLAGS+= -Wl,-rpath,${LOCALBASE}/lib
MAN1= CA.pl.1 asn1parse.1 ca.1 ciphers.1 crl.1 crl2pkcs7.1 dgst.1 dhparam.1 \
@@ -849,7 +872,7 @@ pre-everything::
@${FALSE}
.endif
-PKGNAMESUFFIX= -overwrite-base
+BASE_SUFFIX= -overwrite-base
PREFIX= /usr
OPENSSLDIR= /etc/ssl
MANPREFIX= ${PREFIX}/openssl